Forum Replies Created
-
wpsolrKeymaster7 years, 6 months ago in reply to: Amazon AWS Elasticsearch Error #10984
No need of Solr, if you have an AWS Elasticsearch cluster configured.
Verify that you have cURL and php cURL libraries installed, and that you can access AWS Elasticsearch (ask your hosting provider).
See a similar error solved here (“Internal Server Error”): /forums/topic/unable-to-connect-to-bonsai-elastisearch/
wpsolrKeymaster7 years, 6 months ago in reply to: Amazon AWS Elasticsearch Error #10982What can you see in your WordPress debug.log file?
wpsolrKeymaster7 years, 6 months ago in reply to: Amazon AWS Elasticsearch Error #10980Which company is hosting your WordPress?
wpsolrKeymaster7 years, 6 months ago in reply to: Non-profit organization #10978Yes, we have a global search: /guide/configuration-step-by-step-schematic/activate-extensions/extension-premium/cross-domain-search/
wpsolrKeymaster7 years, 6 months ago in reply to: WPSOLR: error on term #10946It is the right syntax, but the ‘ are to be replaced with simple quotes ‘ . Probably a copy/paste issue.
I tested the query.
wpsolrKeymaster7 years, 6 months ago in reply to: WPSOLR: error on term #10943Execute the SQL query to get the “ID” column, and edit the post.
wpsolrKeymaster7 years, 6 months ago in reply to: Woocommerce orders are not showing #10940Here is the documentation: /knowledgebase/woocommerce-pack-can-replace-woocommerce-orders-search-wpsolr-search/
wpsolrKeymaster7 years, 6 months ago in reply to: Woocommerce orders are not showing #10939I guess you checked “Search in orders” on the WPSOLR WooCommerce add-on.
You now need to index orders in screen 2.2. Select also all the custom fields you need (billing, rices, …).
Do not forget to index orders after updating screen 2.2.wpsolrKeymaster7 years, 6 months ago in reply to: WPSOLR: error on term #10936You attempted to edit an item that doesn’t exist. Perhaps it was deleted?
Perhaps. But apparently, it is still used in your products.
To detect which one, you can index with “batch number” equals to 1, and with the debug option checked. You should be able to see the product id displayed when the indexing stops on error.
And can you further explain why the orders are not showing up ?
Please create a new topic for this issue.
- This reply was modified 7 years, 6 months ago by wpsolr.
wpsolrKeymaster7 years, 6 months ago in reply to: WPSOLR: error on term #10934Can you edit the term 534 of taxonomy “manufacturer” in WP admin?
wpsolrKeymaster7 years, 7 months ago in reply to: Server configuration #10926Please copy your commands here if you think they are useful for the community.
wpsolrKeymaster7 years, 7 months ago in reply to: re indexing hook #10924Hi,
WPSOLR has an extension named “Crons”. It lets you define an HTTP access point that you can call to reindex from a cron or any other means.
/forums/forum/features/crontab-api-generator/
wpsolrKeymaster7 years, 7 months ago in reply to: Download the latest version #10910You can also download manually the latest WPSOLR version from your account.
/knowledgebase/migrate-wpsolr-wpsolr-pro/
wpsolrKeymaster7 years, 7 months ago in reply to: is_page() error in class-wpsolr-plugin-woocommerce.php resulting in null-object #10906Fine.
wpsolrKeymaster7 years, 7 months ago in reply to: is_page() error in class-wpsolr-plugin-woocommerce.php resulting in null-object #10904Probably a cache effect.
It’s not complete, because in your current version, I deactivated completely WPSOLR on home with shop static page. If you add the WPSOLR facets on home now, you will not see them. Some clients want that feature.
Can you install the right version below, with WPSOLR active on home shop page? Check that your caches are cleared.
https://www.dropbox.com/s/d8ca89fi9sex5ee/wpsolr-pro-fix-home-shop-4.zip?dl=0