is_page() error in class-wpsolr-plugin-woocommerce.php resulting in null-object

  • leomoon
    Participant
    # 8 months, 2 weeks ago

    If you think this will help, I can definitely send you my activepayments license until you debug it and then if you deactivate it, I can activate it on my side again. The site is not used yet so I can live without active payments for temporarily.

    wpsolr
    Keymaster
    # 8 months, 2 weeks ago

    I just bought one activepayments license, activated a payment gateway, and debugged an “Add to card” action.

    The debugger followed exactly the path shown in your error stack trace, but without any error.

    The difference I notice is that in my case, the “Add to card” action is an Ajax call to /?wc-ajax=add_to_cart
    Do you have an idea why yours is not Ajax, but a redirection to ?add-to-cart=10718 ?

    (I also use the Book theme, and the Powerpack plugin))

    leomoon
    Participant
    # 8 months, 2 weeks ago

    The AJAX add to cart setting is in woocommerce/settings/products tab and yes, I have it turned off because the advanced messages for woocommerce plugin which is used to display messages on top about how much you need to add to get free shipping does not react to ajax changes.
    This is a feature I should request from the makers of that plugin really, but if you want to replicate this particular problem, you can uncheck use ajax add to cart in woocommerce/settings/products.

    wpsolr
    Keymaster
    # 8 months, 2 weeks ago

    Thanks. Still no errors here without Ajax.

    leomoon
    Participant
    # 8 months, 2 weeks ago

    This is unbelievable, but, I checked AJAX cart and no errors, and now unchecked it again, and… NO ERRORS!? As if resetting that setting did something.
    Either way, the case finally closed with this milestone 50th reply!

    Thanks for all the energy and lightning fast responses.

    wpsolr
    Keymaster
    # 8 months, 2 weeks ago

    Probably a cache effect.

    It’s not complete, because in your current version, I deactivated completely WPSOLR on home with shop static page. If you add the WPSOLR facets on home now, you will not see them. Some clients want that feature.

    Can you install the right version below, with WPSOLR active on home shop page? Check that your caches are cleared.

    https://www.dropbox.com/s/d8ca89fi9sex5ee/wpsolr-pro-fix-home-shop-4.zip?dl=0

    leomoon
    Participant
    # 8 months, 2 weeks ago

    I am using faucets as well 🙂

    Now after this latest version, the homepage errors are back again, and what I said about them being gone on add to cart was not actually real because I forgot I applied that $page null check which effectively eliminates these errors.

    But don’t waste any more time on this – lets wait until someone else reports it as well. My fix in class-wp-query.php works well for now.

    wpsolr
    Keymaster
    # 8 months, 2 weeks ago

    Fine.

Viewing 8 posts - 46 through 53 (of 53 total)

You must be logged in to reply to this topic.