Forum Replies Created

  • wpsolr
    Keymaster

    I sent you an invite to a private Trello board to check out this particular issue.

    wpsolr
    Keymaster

    I understand that you selected custom fields on your “White papers” post type, but they are not saved.
    Do you see javascript errors in the debug console?

    wpsolr
    Keymaster
    4 years, 7 months ago in reply to: Multisite Network license purchase process #29326

    Can you please create a new topic for d. ?

    wpsolr
    Keymaster
    4 years, 7 months ago in reply to: Multisite Network license purchase process #29325

    a. Volume pricing is fully detailed on our pricing page
    b. Of course, just create a new topic on this forum. But you must know we do not provide one-to-one support as part of the standard support.
    c. Yes, the plugin supports OpenSearch. We are also currently integrating to Pantheon’s Solr add-on service.

    wpsolr
    Keymaster
    4 years, 7 months ago in reply to: Multisite Network license #29316

    Thanks, but we only provide the discounts shown on our pricing page.
    Subscriptions are yearly, which means they will stop working after the due date anniversary.

    wpsolr
    Keymaster
    4 years, 7 months ago in reply to: Multisite Network license #29300

    Hi,
    Volume discount pricing is displayed on the pricing page.

    • This reply was modified 4 years, 7 months ago by wpsolr.
    wpsolr
    Keymaster
    4 years, 7 months ago in reply to: WPSolr not replacing WP_Query #29206

    WPSOLR only replaces WordPress archive page queries: search, taxonomies, post types …

    wpsolr
    Keymaster
    4 years, 8 months ago in reply to: Is wpsolr plugin doing auto index? #29180

    Indeed, WPSOLR provides real-time indexing of data.

    In fact, WPSOLR supports indexing with:
    – Real-time mode: post types are (re)indexed every time a post type is created/updated/deleted.
    – Batch mode: you (re)index manually from WPSOLR’s admin
    – Unix Crontabs mode: you define what you want to index, WPSOLR generates a protected url than you can call from your unix crontabs ouside of WP. Useful to reindex everything after importing tens of thousands of post types every night for instance.

    • This reply was modified 4 years, 8 months ago by wpsolr.
    • This reply was modified 4 years, 8 months ago by wpsolr.
    wpsolr
    Keymaster
    4 years, 8 months ago in reply to: meta data shown in search results #29170

    PDF is one of the many text formats extracted by the Tika library, in Solr.

    The way it is done is show in my previous answer, with the parameter ignored_ in solrconfig.xml installed by WPSOLR on your index, which is Solr’s way to ask for no meta data extracted from the PDF.

    This is a default setup, but you can tweak it eventually as discussed in https://stackoverflow.com/questions/47934257/importing-files-with-solr-cell-tika-is-mixing-metadata-fields-with-content

    wpsolr
    Keymaster
    4 years, 8 months ago in reply to: Error PHP 8.1 #29169

    What is this answer? Is it supposed to help me fix the issues for the client?

    It just means I could not replicate your issue on my environments. I gave you my Solr version, so you can compare to yours eventually. You can eventually set a whitespace character to all your description by hand or code, as a workaround.

    All of that after paying 400$ plus sysadmin to upgrade from Solr V5.4

    This has nothing to do with WPSOLR. We do not install, maintain, or host Solr for clients. But we provide connectors to some Solr hosting services, like Opensolr or Searchstax, if you do not want to do it.

    Still having Invalid UTF-8 middle byte 0x3c

    This is an error that comes from a format problem in documents. Nothing that can be fixed. You can check similar issue on /forums/topic/indexing-error-invalid-utf-8-middle-byte-0x3c/.

    Please create a topic for each of those issues. It will be easier to follow up each problem individually.

    This topic was about PHP 8.1, and was mentioned by you as solved, therefore closed.

    • This reply was modified 4 years, 8 months ago by wpsolr.
    • This reply was modified 4 years, 8 months ago by wpsolr.
    • This reply was modified 4 years, 8 months ago by wpsolr.
    wpsolr
    Keymaster
    4 years, 8 months ago in reply to: meta data shown in search results #29163

    In the solrconfig.xml installed by WPSOLR with each new index, meta informations are marked to be ignored:

    < requestHandler name="/update/extract" startup="lazy" class="solr.extraction.ExtractingRequestHandler" >
    < lst name="defaults">
    < str name="lowernames">true< /str>
    < str name="fmap.meta">ignored_< /str>
    < str name="fmap.content">_text_< /str>
    < /lst>
    < /requestHandler>

    • This reply was modified 4 years, 8 months ago by wpsolr.
    • This reply was modified 4 years, 8 months ago by wpsolr.
    • This reply was modified 4 years, 8 months ago by wpsolr.
    wpsolr
    Keymaster
    4 years, 8 months ago in reply to: Error PHP 8.1 #29162

    I just tested indexing some posts with only a title with Solr 8.9. It went well.

    wpsolr
    Keymaster
    wpsolr
    Keymaster
    4 years, 8 months ago in reply to: Error PHP 8.1 #29156

    As other PDfs are indexed fine, you should prevent this PDF being indexed: edit your post and use the WPSOLR’s meta box check box “Do not search” for that.

    wpsolr
    Keymaster
    4 years, 8 months ago in reply to: Error PHP 8.1 #29154

    Can you describe the problem/error?

Viewing 15 posts - 1,276 through 1,290 (of 3,679 total)