Forum Replies Created
-
wpsolrKeymaster3 years ago in reply to: Facets items with certain characters in string do not filter content #35823
What is your search engine?
wpsolrKeymaster3 years ago in reply to: Indexing Error #35822The Solr version supported by WPSOLR is Solr 9.x
wpsolrKeymaster3 years ago in reply to: Facets items with certain characters in string do not filter content #35819This is correct: the “:” character is not supported in facet labels. For now, the only way to prevent the problem is to not use “:” in your facets.
wpsolrKeymaster3 years ago in reply to: Facets items not filtering content and solr error on page refresh #35817The facet error comes from the Solr server. Probably not enough resources to calculate too many facets containing too many items.
You can limit the number of facets, or the number of items, or ask your Solr hosting provider about the error trace.
For the other issue, please create a new topic.
wpsolrKeymaster3 years ago in reply to: Bug when filtering taxonomy term as a non logged in user #35813Indeed. Product is a custom post type, and product-category is a custom taxonomy, both brought by WooCommerce.
wpsolrKeymaster3 years ago in reply to: Facets items not filtering content and solr error on page refresh #35810How many facet items did you set in screen 2.1?
I suspect too many items are returned.wpsolrKeymaster3 years ago in reply to: Bug when filtering taxonomy term as a non logged in user #35771I cannot reproduce your issue. Check our demo https://demo-woocommerce-flatsome-cloudways.wpsolr.com/product-category/clothing/
wpsolrKeymaster3 years ago in reply to: Where top find setup files for Solr 8.1? #35768WPSOLR only works with Solr 9.x version. Other versions will lead to configuration errors.
wpsolrKeymaster3 years ago in reply to: Indexing Error #35733The Solr version supported by WPSOLR is Solr 9.x
Your error comes from our solrconfig.xml containing a cache “solr.CaffeineCache”, not valid for Solr 7.x
wpsolrKeymaster3 years ago in reply to: Indexing Error #35731You can follow the video at /guide/configuration-step-by-step-schematic/configure-your-indexes/connect-to-an-apache-solr-index/
wpsolrKeymaster3 years ago in reply to: Custom sorting facet values #35712You can use hook
WPSOLR_Events::WPSOLR_FILTER_UPDATE_FACETS_DATAto reorder facet items to your liking.An example can be found in file
wpsolr/pro/extensions/seo/class-wpsolr-option-seo.phpwpsolrKeymaster3 years ago in reply to: Indexing Error #35711I then advise to create a new index with http, and see if logs continue to show https.
wpsolrKeymaster3 years ago in reply to: Indexing Error #35709Why does your trace error mention https://localhost:8983/solr/snfpaper2/update/extract?… ?
wpsolrKeymaster3 years ago in reply to: Indexing Error #35701Can you try without https?
wpsolrKeymaster3 years ago in reply to: Indexing Error #35697The error occurs before the debug trace, hence the absence of logs.
I noticed your solr url is https://localhost:8983. This kind of error message can happen if you do not use a self-signed CA certificate with https.