Forum Replies Created
-
wpsolrKeymaster7 years, 8 months ago in reply to: help with storing large text fields #10145
Unfortunately, I cannot generate a new fix at the moment.
You can just edit the file /home/*******/httpdocs/wp-content/plugins/wpsolr-pro/wpsolr/pro/extensions/theme/layout/ion_range_slider/class-wpsolr-ui-layout-ion-range-slider.php, and replace <? with <?php at line 40.
Or enable php short tags.
The fix will come officially in release 21.3.
wpsolrKeymaster7 years, 8 months ago in reply to: Fatal error activating plugin #10140At least PHP 5.6.5.
class-wpsolr-option.php on line 233
Do you have the exact same error?
wpsolrKeymaster7 years, 8 months ago in reply to: WPSOLR indexing page attachments #10138That being said, WPSOLR seems to be indexing page attachments (media files) is there a quick way to stop this from happening?
What makes you think your attachments are indexed?
wpsolrKeymaster7 years, 8 months ago in reply to: Replacement for Existing Search/Filtering Functionality #10134If you need a custom work
wpsolrKeymaster7 years, 8 months ago in reply to: Wpsolr Pro 21.2 update produced fatal error #10120Yes, indeed.
wpsolrKeymaster7 years, 8 months ago in reply to: Wpsolr Pro 21.2 update produced fatal error #10118It appears it could be a short tag in the file (line 40). I will disable short tags during my automated tests to prevent this error ever happen again.
wpsolrKeymaster7 years, 8 months ago in reply to: help with storing large text fields #10116It appears it could be a short tag in the file (line 40). I will disable short tags during my automated tests to prevent this error ever happen again.
wpsolrKeymaster7 years, 8 months ago in reply to: WPSOLR indexing page attachments #10115Yes, do not select attachments post type in screen 2.2
wpsolrKeymaster7 years, 8 months ago in reply to: help with storing large text fields #10114What is your OS, and PHP version?
wpsolrKeymaster7 years, 8 months ago in reply to: elasticpress.io hosting? #10111elasticpress.io hosting integration is released in WPSOLR 21.3
Here is the documentation: elasticpress.io hosting documentation
wpsolrKeymaster7 years, 8 months ago in reply to: Display all pages with sort faceting #10080Hi,
Yes, it is just the search page without keywords: /?s
Try this site search without keywords. You’ll see all the content, and can use the filters.wpsolrKeymaster7 years, 8 months ago in reply to: help with storing large text fields #10077Please replace WPSOLR with https://www.dropbox.com/s/dw5vqnr2j2q4ger/wpsolr-pro.zip?dl=0 (this link is valid for one hour)
It should prevent the “immense term” error, for Solr and Elasticsearch.
wpsolrKeymaster7 years, 8 months ago in reply to: help with storing large text fields #10075THanks.
I could reproduce your issue in my environment, and fixed it. I also added the automated tests to prevent the bug coming back in the future. It will be delivered with the next release.
If you want the fix now, let me know.
wpsolrKeymaster7 years, 8 months ago in reply to: Wpsolr Pro 21.2 update produced fatal error #10071What is your OS?
wpsolrKeymaster7 years, 8 months ago in reply to: Wpsolr Pro 21.2 update produced fatal error #10069This file was Selenium tested, and its content checked with PHP Compatibility Checker for PHP 5.6.5 and 7.2
I also open it in without errors in phpstorm.Perhaps the file is corrupted.