Fatal error activating plugin

  • bijankani
    Participant
    3 years, 10 months ago #9671

    Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected ‘[‘ in D:\picarchivenew\wordpress\wp-content\plugins\wpsolr-pro\wpsolr\core\classes\utilities\class-wpsolr-option.php on line 233

    wpsolr
    Keymaster
    3 years, 10 months ago #9672

    Hi,

    Since WPSOLR 21.0, PHP 5.6.5 is required: see changelog

    joehobson
    Participant
    3 years, 10 months ago #10139

    When you say “PHP 5.6.5 is required” do you mean that it has to be exactly that version, or at least that version?

    I’m seeing that error with PHP Version 5.6.13 on Ubuntu 14.04, via Apache 2.4.7 and WordPress 4.9.8

    wpsolr
    Keymaster
    3 years, 10 months ago #10140

    At least PHP 5.6.5.

    class-wpsolr-option.php on line 233

    Do you have the exact same error?

    joehobson
    Participant
    3 years, 9 months ago #10196

    Yes, exact same error when i try to activate. WPSOLR PRO v21.1

    (also, your help forums “Notify me of follow-up replies via email” does not appear to work)

    tientq
    Participant
    3 years, 9 months ago #10200

    @joehobson: upgrade your php. It will fix the problem

    joehobson
    Participant
    3 years, 9 months ago #10204

    thanks @tientq, but that didn’t help. Still seeing the same error using PHP Version 5.6.40-1+ubuntu14.04.1+deb.sury.org+1

    wpsolr
    Keymaster
    3 years, 9 months ago #10206

    Try upgrade to 7.x if you can.

    Next release WPSOLR 21.3 will require PHP 7.x anyway.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.