WooCommerce 4.4.1 Archive Pages not showing products

  • wpsolr
    Keymaster
    2 years, 5 months ago #21528

    Can you activate the Elasticsearch debug mode in screen 2.1, then check the query of shop page?

    wpsolr
    Keymaster
    2 years, 5 months ago #21529

    Here is a working demo version with a similar environment (on Cloudways, with their local Elasticsearch): https://demo-woocommerce-shoptimizer-cloudways.wpsolr.com/shop/

    WordPress version: 5.5
    WooCommerce version: 4.4.1
    WPSOLR version : 2.1.8
    PHP version : 7.4
    Elasticsearch version: 6.5

    wpsolr
    Keymaster
    2 years, 5 months ago #21530

    Can you display the full error message from your logs here?

    ukatr
    Participant
    2 years, 5 months ago #21531

    sorry i can’t find debug mode setting in 2.1!

    wpsolr
    Keymaster
    2 years, 5 months ago #21533

    Sorry, query logging will be available in next release.

    ukatr
    Participant
    2 years, 5 months ago #21534

    Got it, so what should I do now?

    wpsolr
    Keymaster
    2 years, 5 months ago #21535

    Check for a plugin conflict, by deactivating other plugins.

    ukatr
    Participant
    2 years, 5 months ago #21536

    I’ve tested this, the problem seems to be no plugin conflict.

    wpsolr
    Keymaster
    2 years, 5 months ago #21537

    Can you check your Elasticsearch logs?

    ukatr
    Participant
    2 years, 5 months ago #21538

    Can you give me an email address so I can send the logs to you?

    wpsolr
    Keymaster
    2 years, 5 months ago #21539

    Can you just copy an extract here?

    ukatr
    Participant
    2 years, 5 months ago #21540

    [2020-08-21T01:30:00,011][INFO ][o.e.x.m.MlDailyMaintenanceService] [NsI6m2F] triggering scheduled [ML] maintenance tasks
    [2020-08-21T01:30:00,076][INFO ][o.e.x.m.a.TransportDeleteExpiredDataAction] [NsI6m2F] Deleting expired data
    [2020-08-21T01:30:00,133][INFO ][o.e.x.m.a.TransportDeleteExpiredDataAction] [NsI6m2F] Completed deletion of expired data
    [2020-08-21T01:30:00,134][INFO ][o.e.x.m.MlDailyMaintenanceService] [NsI6m2F] Successfully completed [ML] maintenance tasks
    [2020-08-21T10:33:27,053][DEBUG][o.e.a.s.TransportSearchAction] [NsI6m2F] [dekoo_es_live_search_engine][3], node[NsI6m2FdQy2wv5qoQA65Fg], [P], s[STARTED], a[id=gYYWD8-9TUiAL5mxcTokYA]: Failed to execute [SearchRequest{searchType=QUERY_THEN_FETCH, indices=[dekoo_es_live_search_engine], indicesOptions=IndicesOptions[ignore_unavailable=false, allow_no_indices=true, expand_wildcards_open=true, expand_wildcards_closed=false, allow_aliases_to_multiple_indices=true, forbid_closed_indices=true, ignore_aliases=false], types=[], routing=’null’, preference=’null’, requestCache=null, scroll=null, maxConcurrentShardRequests=5, batchedReduceSize=512, preFilterShardSize=128, allowPartialSearchResults=true, source={“from”:10960,”size”:40,”query”:{“bool”:{“must”:[{“query_string”:{“query”:”text:(*)”,”fields”:[],”type”:”best_fields”,”default_operator”:”and”,”max_determinized_states”:10000,”enable_position_increments”:true,”fuzziness”:”AUTO”,”fuzzy_prefix_length”:0,”fuzzy_max_expansions”:50,”phrase_slop”:0,”escape”:false,”auto_generate_synonyms_phrase_query”:true,”fuzzy_transpositions”:true,”boost”:1.0}}],”filter”:[{“bool”:{“must”:[{“terms”:{“type”:[“product”],”boost”:1.0}},{“bool”:{“must_not”:[{“terms”:{“post_status_s”:[“draft”,”pending”,”trash”,”future”,”private”,”auto-draft”],”boost”:1.0}}],”adjust_pure_negative”:true,”boost”:1.0}},{“bool”:{“must”:[{“term”:{“non_flat_hierarchy_product_cat_str”:{“value”:”İnsan ve Toplum”,”boost”:1.0}}}],”adjust_pure_negative”:true,”boost”:1.0}},{“bool”:{“should”:[{“bool”:{“must_not”:[{“exists”:{“field”:”product_visibility_str”,”boost”:1.0}}],”adjust_pure_negative”:true,”boost”:1.0}},{“bool”:{“must_not”:[{“terms”:{“product_visibility_str”:[“exclude-from-catalog”],”boost”:1.0}}],”adjust_pure_negative”:true,”boost”:1.0}}],”adjust_pure_negative”:true,”boost”:1.0}},{“bool”:{“should”:[{“bool”:{“must_not”:[{“bool”:{“must”:[{“exists”:{“field”:”is_excluded_s”,”boost”:1.0}}],”adjust_pure_negative”:true,”boost”:1.0}}],”adjust_pure_negative”:true,”boost”:1.0}},{“terms”:{“is_excluded_s”:[“n”],”boost”:1.0}}],”adjust_pure_negative”:true,”boost”:1.0}},{“bool”:{“must_not”:[{“terms”:{“_id”:[“wpsolr_doc_id_attachment”],”boost”:1.0}}],”adjust_pure_negative”:true,”boost”:1.0}}],”adjust_pure_negative”:true,”boost”:1.0}}],”adjust_pure_negative”:true,”boost”:1.0}},”_source”:{“includes”:[“id”,”PID”,”type”,”meta_type_s”,”title”,”numcomments”,”comments”,”displaydate”,”displaymodified”,”*categories_str”,”author”,”*post_thumbnail_href_str”,”*post_href_str”,”snippet_s”],”excludes”:[]},”sort”:[{“date”:{“order”:”desc”}}],”aggregations”:{“flat_hierarchy_product_cat_str”:{“filter”:{“match_all”:{“boost”:1.0}},”aggregations”:{“flat_hierarchy_product_cat_str”:{“terms”:{“field”:”flat_hierarchy_product_cat_str”,”size”:10,”min_doc_count”:1,”shard_min_doc_count”:0,”show_term_doc_count_error”:false,”order”:[{“_count”:”desc”},{“_key”:”asc”}]}}}},”pa_yazar_str”:{“filter”:{“match_all”:{“boost”:1.0}},”aggregations”:{“pa_yazar_str”:{“terms”:{“field”:”pa_yazar_str”,”size”:10,”min_doc_count”:1,”shard_min_doc_count”:0,”show_term_doc_count_error”:false,”order”:[{“_count”:”desc”},{“_key”:”asc”}]}}}}}}}] lastShard [true]
    org.elasticsearch.transport.RemoteTransportException: [NsI6m2F][127.0.0.1:9300][indices:data/read/search[phase/query]]
    Caused by: org.elasticsearch.search.query.QueryPhaseExecutionException: Result window is too large, from + size must be less than or equal to: [10000] but was [11000]. See the scroll api for a more efficient way to request large data sets. This limit can be set by changing the [index.max_result_window] index level setting.
    at org.elasticsearch.search.DefaultSearchContext.preProcess(DefaultSearchContext.java:211) ~[elasticsearch-6.5.1.jar:6.5.1]
    at org.elasticsearch.search.query.QueryPhase.preProcess(QueryPhase.java:89) ~[elasticsearch-6.5.1.jar:6.5.1]
    at org.elasticsearch.search.SearchService.createContext(SearchService.java:628) ~[elasticsearch-6.5.1.jar:6.5.1]
    at org.elasticsearch.search.SearchService.createAndPutContext(SearchService.java:592) ~[elasticsearch-6.5.1.jar:6.5.1]
    at org.elasticsearch.search.SearchService.executeQueryPhase(SearchService.java:367) ~[elasticsearch-6.5.1.jar:6.5.1]
    at org.elasticsearch.search.SearchService.access$100(SearchService.java:121) ~[elasticsearch-6.5.1.jar:6.5.1]
    at org.elasticsearch.search.SearchService$2.onResponse(SearchService.java:339) [elasticsearch-6.5.1.jar:6.5.1]
    at org.elasticsearch.search.SearchService$2.onResponse(SearchService.java:335) [elasticsearch-6.5.1.jar:6.5.1]
    at org.elasticsearch.search.SearchService$4.doRun(SearchService.java:1082) [elasticsearch-6.5.1.jar:6.5.1]
    at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingAbstractRunnable.doRun(ThreadContext.java:723) [elasticsearch-6.5.1.jar:6.5.1]
    at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37) [elasticsearch-6.5.1.jar:6.5.1]
    at org.elasticsearch.common.util.concurrent.TimedRunnable.doRun(TimedRunnable.java:41) [elasticsearch-6.5.1.jar:6.5.1]
    at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37) [elasticsearch-6.5.1.jar:6.5.1]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) [?:?]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) [?:?]
    at java.lang.Thread.run(Thread.java:834) [?:?]
    [2020-08-21T10:33:27,055][DEBUG][o.e.a.s.TransportSearchAction] [NsI6m2F] [dekoo_es_live_search_engine][2], node[NsI6m2FdQy2wv5qoQA65Fg], [P], s[STARTED], a[id=_LfR4E9dSFaKaNyIl4pBFw]: Failed to execute [SearchRequest{searchType=QUERY_THEN_FETCH, indices=[dekoo_es_live_search_engine], indicesOptions=IndicesOptions[ignore_unavailable=false, allow_no_indices=true, expand_wildcards_open=true, expand_wildcards_closed=false, allow_aliases_to_multiple_indices=true, forbid_closed_indices=true, ignore_aliases=false], types=[], routing=’null’, preference=’null’, requestCache=null, scroll=null, maxConcurrentShardRequests=5, batchedReduceSize=512, preFilterShardSize=128, allowPartialSearchResults=true, source={“from”:10960,”size”:40,”query”:{“bool”:{“must”:[{“query_string”:{“query”:”text:(*)”,”fields”:[],”type”:”best_fields”,”default_operator”:”and”,”max_determinized_states”:10000,”enable_position_increments”:true,”fuzziness”:”AUTO”,”fuzzy_prefix_length”:0,”fuzzy_max_expansions”:50,”phrase_slop”:0,”escape”:false,”auto_generate_synonyms_phrase_query”:true,”fuzzy_transpositions”:true,”boost”:1.0}}],”filter”:[{“bool”:{“must”:[{“terms”:{“type”:[“product”],”boost”:1.0}},{“bool”:{“must_not”:[{“terms”:{“post_status_s”:[“draft”,”pending”,”trash”,”future”,”private”,”auto-draft”],”boost”:1.0}}],”adjust_pure_negative”:true,”boost”:1.0}},{“bool”:{“must”:[{“term”:{“non_flat_hierarchy_product_cat_str”:{“value”:”İnsan ve Toplum”,”boost”:1.0}}}],”adjust_pure_negative”:true,”boost”:1.0}},{“bool”:{“should”:[{“bool”:{“must_not”:[{“exists”:{“field”:”product_visibility_str”,”boost”:1.0}}],”adjust_pure_negative”:true,”boost”:1.0}},{“bool”:{“must_not”:[{“terms”:{“product_visibility_str”:[“exclude-from-catalog”],”boost”:1.0}}],”adjust_pure_negative”:true,”boost”:1.0}}],”adjust_pure_negative”:true,”boost”:1.0}},{“bool”:{“should”:[{“bool”:{“must_not”:[{“bool”:{“must”:[{“exists”:{“field”:”is_excluded_s”,”boost”:1.0}}],”adjust_pure_negative”:true,”boost”:1.0}}],”adjust_pure_negative”:true,”boost”:1.0}},{“terms”:{“is_excluded_s”:[“n”],”boost”:1.0}}],”adjust_pure_negative”:true,”boost”:1.0}},{“bool”:{“must_not”:[{“terms”:{“_id”:[“wpsolr_doc_id_attachment”],”boost”:1.0}}],”adjust_pure_negative”:true,”boost”:1.0}}],”adjust_pure_negative”:true,”boost”:1.0}}],”adjust_pure_negative”:true,”boost”:1.0}},”_source”:{“includes”:[“id”,”PID”,”type”,”meta_type_s”,”title”,”numcomments”,”comments”,”displaydate”,”displaymodified”,”*categories_str”,”author”,”*post_thumbnail_href_str”,”*post_href_str”,”snippet_s”],”excludes”:[]},”sort”:[{“date”:{“order”:”desc”}}],”aggregations”:{“flat_hierarchy_product_cat_str”:{“filter”:{“match_all”:{“boost”:1.0}},”aggregations”:{“flat_hierarchy_product_cat_str”:{“terms”:{“field”:”flat_hierarchy_product_cat_str”,”size”:10,”min_doc_count”:1,”shard_min_doc_count”:0,”show_term_doc_count_error”:false,”order”:[{“_count”:”desc”},{“_key”:”asc”}]}}}},”pa_yazar_str”:{“filter”:{“match_all”:{“boost”:1.0}},”aggregations”:{“pa_yazar_str”:{“terms”:{“field”:”pa_yazar_str”,”size”:10,”min_doc_count”:1,”shard_min_doc_count”:0,”show_term_doc_count_error”:false,”order”:[{“_count”:”desc”},{“_key”:”asc”}]}}}}}}}] lastShard [true]
    org.elasticsearch.transport.RemoteTransportException: [NsI6m2F][127.0.0.1:9300][indices:data/read/search[phase/query]]
    Caused by: org.elasticsearch.search.query.QueryPhaseExecutionException: Result window is too large, from + size must be less than or equal to: [10000] but was [11000]. See the scroll api for a more efficient way to request large data sets. This limit can be set by changing the [index.max_result_window] index level setting.
    at org.elasticsearch.search.DefaultSearchContext.preProcess(DefaultSearchContext.java:211) ~[elasticsearch-6.5.1.jar:6.5.1]
    at org.elasticsearch.search.query.QueryPhase.preProcess(QueryPhase.java:89) ~[elasticsearch-6.5.1.jar:6.5.1]
    at org.elasticsearch.search.SearchService.createContext(SearchService.java:628) ~[elasticsearch-6.5.1.jar:6.5.1]
    at org.elasticsearch.search.SearchService.createAndPutContext(SearchService.java:592) ~[elasticsearch-6.5.1.jar:6.5.1]
    at org.elasticsearch.search.SearchService.executeQueryPhase(SearchService.java:367) ~[elasticsearch-6.5.1.jar:6.5.1]
    at org.elasticsearch.search.SearchService.access$100(SearchService.java:121) ~[elasticsearch-6.5.1.jar:6.5.1]
    at org.elasticsearch.search.SearchService$2.onResponse(SearchService.java:339) [elasticsearch-6.5.1.jar:6.5.1]
    at org.elasticsearch.search.SearchService$2.onResponse(SearchService.java:335) [elasticsearch-6.5.1.jar:6.5.1]
    at org.elasticsearch.search.SearchService$4.doRun(SearchService.java:1082) [elasticsearch-6.5.1.jar:6.5.1]
    at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingAbstractRunnable.doRun(ThreadContext.java:723) [elasticsearch-6.5.1.jar:6.5.1]
    at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37) [elasticsearch-6.5.1.jar:6.5.1]
    at org.elasticsearch.common.util.concurrent.TimedRunnable.doRun(TimedRunnable.java:41) [elasticsearch-6.5.1.jar:6.5.1]
    at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37) [elasticsearch-6.5.1.jar:6.5.1]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) [?:?]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) [?:?]
    at java.lang.Thread.run(Thread.java:834) [?:?]

    wpsolr
    Keymaster
    2 years, 5 months ago #21541

    Your logs show that you reached the 10,000 Elasticsearch limit.

    A solution is detailed at https://www.wpsolr.com/forums/topic/remove-10000-limit-when-using-elasticsearch/

    ukatr
    Participant
    2 years, 5 months ago #21543

    https://www.wpsolr.com/fix-elasticsearch-error-result-window-is-too-large/ I have applied the solution on this page for this problem before. This was an error I got after a certain page in paging, and when I applied the solution, the problem was fixed.

    That’s not the problem right now, filters are showing but products are not!

    wpsolr
    Keymaster
    2 years, 5 months ago #21544

    The 10,000 limit error is the last one in your Elasticsearch log?

Viewing 15 posts - 16 through 30 (of 45 total)

You must be logged in to reply to this topic.