WooCommerce 4.4.1 Archive Pages not showing products

  • ukatr
    Participant
    2 years, 4 months ago #21416

    when I click on the product categories, I get the warning “No products matching your selection found”.

    wpsolr
    Keymaster
    2 years, 4 months ago #21417

    Did you select your product categories in tab 2.2 (click on “product”, then on “taxonomies”)?

    • This reply was modified 2 years, 4 months ago by wpsolr.
    ukatr
    Participant
    2 years, 4 months ago #21419

    Yes, I chose taxonomies and added facets to sidebar from the widgets page.

    wpsolr
    Keymaster
    2 years, 4 months ago #21420

    Do you have products in your index? (tab “3. Send your data”)

    ukatr
    Participant
    2 years, 4 months ago #21421

    Yes

    wpsolr
    Keymaster
    2 years, 4 months ago #21422

    Can you check:

    – There are no errors in debug.log
    – “Replace categories” is selected in WPSOLR WooCommerce extension.

    ukatr
    Participant
    2 years, 3 months ago #21506

    – no error
    – yes selected.

    wpsolr
    Keymaster
    2 years, 3 months ago #21507

    Which versions are you using for?
    – WPSOLR
    – WordPress
    – PHP
    – Solr/Elasticsearch

    • This reply was modified 2 years, 3 months ago by wpsolr.
    ukatr
    Participant
    2 years, 3 months ago #21516

    Hello, I reconfigured the settings and re-indexed, then the problem was fixed.

    But when I check today, the filters appear but the products are not listed! https://prntscr.com/u2mzsq

    Settings: https://prntscr.com/u2mzur , https://prntscr.com/u2mzwa , https://prntscr.com/u2mzy8 , https://prntscr.com/u2mzzp

    ukatr
    Participant
    2 years, 3 months ago #21517

    When the wpsolr plugin is active, the following warnings appear on the main page.

    Notice: Trying to get property ‘ID’ of non-object in /home/…/…/public_html/wp-includes/class-wp-query.php on line 4019
    Notice: Trying to get property ‘post_title’ of non-object in /home/…/…/public_html/wp-includes/class-wp-query.php on line 4021
    Notice: Trying to get property ‘post_name’ of non-object in /home/…/…/public_html/wp-includes/class-wp-query.php on line 4023

    ukatr
    Participant
    2 years, 3 months ago #21518

    WordPress version: 5.5
    WooCommerce version: 4.4.1
    WPSOLR version : 2.1.8
    PHP version : 7.3
    Elasticsearch version: 6.5

    wpsolr
    Keymaster
    2 years, 3 months ago #21519

    It could be that your index contains data from another WP instance, hence the IDs not recognized.
    Can you delete and re-index your index content? Or create a new one?

    ukatr
    Participant
    2 years, 3 months ago #21520

    ok i try right now.

    ukatr
    Participant
    2 years, 3 months ago #21521

    I triggered the delete this configuration button by activating the delete the index option in the Connect to your index page. Then I created a new configuration and re-indexed, but I still get the alerts on the homepage and the products are still not listed on the archive pages!

    I suspect the problem is after the WordPress 5.5 update.

    ukatr
    Participant
    2 years, 3 months ago #21527

    Hello again, any ideas?

Viewing 15 posts - 1 through 15 (of 45 total)

You must be logged in to reply to this topic.