Unable to replace the default Wordpress search with WPSOLR search

  • pseudo visitor
    Participant
    # 1 year, 1 month ago

    I followed the instructions, but haven’t been able to replace the default WordPress search with WPSOLR’s.

    (I enabled “Replace WordPress default search by WPSOLR’s.” option in screen 2.1)

    wpsolr
    Keymaster
    # 1 year, 1 month ago

    Please check your Javascript console logs (chrome or firefox).

    You should see this WPSOLR message:
    “WPSOLR PRO : an error prevented the search engine query to be executed. To prevent empty results, the default WordPress query is used instead. Please check the error details in your debug.log file. See https://codex.wordpress.org/Debugging_in_WordPress.”

    Check in your debug.log WordPress log file if an error pops up.

    savt
    Participant
    # 6 months, 3 weeks ago

    Hi, I’ve received that error message on my website:

    “WPSOLR PRO : an error prevented the search engine query to be executed. To prevent empty results, the default WordPress query is used instead. Please check the error details in your debug.log file. See https://codex.wordpress.org/Debugging_in_WordPress.”

    Can I get some advice on how to solve this, please..?

    wpsolr
    Keymaster
    # 6 months, 3 weeks ago

    Can you save your index settings in WPSOLR?

    savt
    Participant
    # 6 months, 3 weeks ago

    (removed for confidentiality)

    • This reply was modified 6 months, 3 weeks ago by  wpsolr. Reason: confidential information
    wpsolr
    Keymaster
    # 6 months, 3 weeks ago

    I noticed your index domain is from aws.found.io.

    Which version of Elasticsearch is it?

    savt
    Participant
    # 6 months, 3 weeks ago

    umm… it’s v6.6.0

    wpsolr
    Keymaster
    # 6 months, 3 weeks ago

    When you see this error, some traces were added by WPSOLR in your debug.log file with error_log() .

    Look for “WPSOLR message:” and “WPSOLR trace:”.

    See https://codex.wordpress.org/Debugging_in_WordPress

    savt
    Participant
    # 6 months, 3 weeks ago

    ok.The following link is the screenshot of the error message:

    View post on imgur.com

    Please let me know if you’re able to view it..?

    wpsolr
    Keymaster
    # 6 months, 3 weeks ago

    Please try:

    1) Can you check that you selected “HTTPS” in your index settings screen?
    2) Can you ssh to your server, and query the Elasticsearch index with cURL?
    3) Please send me your WPSOLR index settings screenshot

    savt
    Participant
    # 6 months, 3 weeks ago

    1: https://imgur.com/a/E4muy64
    2: (confidential information)
    3: https://imgur.com/a/tc0odAF

    • This reply was modified 6 months, 3 weeks ago by  wpsolr. Reason: confidential information
    wpsolr
    Keymaster
    # 6 months, 3 weeks ago

    So, you can connect from a cURL.

    What happens when you click on “Check the index status”?

    savt
    Participant
    # 6 months, 3 weeks ago

    it synchronises , then a green tick appeared on the side and straight away refresh the page.

    wpsolr
    Keymaster
    # 6 months, 3 weeks ago

    You can index your data?

    savt
    Participant
    # 6 months, 3 weeks ago
Viewing 15 posts - 1 through 15 (of 48 total)

You must be logged in to reply to this topic.