Not all products are showing after indexing

  • O-O
    Participant
    # 2 years, 5 months ago

    Hi Patrice,

    The wpsolr is completely setup and all seems to work fine. However I noticed not all products are shown on the website.

    We have in total 32.143 products, and in the index we have 32143 documents.

    But when I search for all products frond-end I only get 953 results. Also some of the product categories are still empty. I tried to delete the whole index and indexed it all again. But still the same results.

    Could you please tell me what I can try to do so all my products will be shown?

    Kind regards,

    Jamie

    wpsolr
    Keymaster
    # 2 years, 5 months ago

    Do you have products and variations?

    O-O
    Participant
    # 2 years, 5 months ago

    Only products

    wpsolr
    Keymaster
    # 2 years, 5 months ago

    Really? This is a typical issue, as variations are not shown in results.

    O-O
    Participant
    # 2 years, 5 months ago

    Yes, our yellow shoe and green shoe are separate products.

    wpsolr
    Keymaster
    # 2 years, 5 months ago

    On your WPSOLR indexing screen, which post types are selected?

    O-O
    Participant
    # 2 years, 5 months ago

    All products and All variations are indexed.

    wpsolr
    Keymaster
    # 2 years, 5 months ago

    So, you have products and variations.

    Variations are only used on a product page. You should remove them from your index.

    O-O
    Participant
    # 2 years, 5 months ago

    I removed the variations at 2.2 but still the same.

    May I give you a login that you can check it?

    wpsolr
    Keymaster
    # 2 years, 5 months ago

    In screen “3. Send you data”, delete you index content, until you see 0 documents in the index. What are the figures you see for “Products” and “Variations” not yet indexed?

    • This reply was modified 2 years, 5 months ago by wpsolr.
    • This reply was modified 2 years, 5 months ago by wpsolr.
    O-O
    Participant
    # 2 years, 5 months ago

    When I add the variation at 2.2 and delete the index at 3 I get:
    32143 Producten not indexed yet. Click on the button “synchronize” to index them.
    All Variaties are indexed.

    O-O
    Participant
    # 2 years, 5 months ago

    Can I sent you an login so you can check it?

    wpsolr
    Keymaster
    # 2 years, 5 months ago

    – in 2.2, uncheck the variations
    – in 3., delete your index content. You should not see variations anymore, 0 documents indexed, and 32143 products to index.

    O-O
    Participant
    # 2 years, 5 months ago

    Yes I have these results

    wpsolr
    Keymaster
    # 2 years, 5 months ago

    Still 32.143 products to index?

Viewing 15 posts - 1 through 15 (of 33 total)

You must be logged in to reply to this topic.