Error upon adding solr_search_shortcode to page

  • mhuntley
    Participant
    11 months, 1 week ago #32816

    Hi WPSolr Folks,

    I currently have a WordPress site and I am following the instructions outlined in this Quick start guide: https://www.wpsolr.com/guide/user-guide-2/ and have generated a test Elasticsearch Index per these instructions: https://www.wpsolr.com/guide/configuration-step-by-step-schematic/configure-your-indexes/generate-temporary-elasticsearch-index-testing/

    After I’ve confirmed all my pages and posts have been indexed, when I add this shortcode to a page to test the Solr search box: [solr_search_shortcode], I get an error from the WordPress CMS: “Updating failed. The response is not a valid JSON response” and, the following error within the console “jQuery” is not defined.

    Then, upon viewing the corresponding front-end page, the Search box appears, but all my queries appear even though not search was conducted.

    Please note my current version of WordPress is 6.1.1 and my current version of jQuery is 3.3.2.

    Could you please advise?

    Best regards,

    wpsolr
    Keymaster
    11 months, 1 week ago #32819

    The shortcode is deprecated.

    Instead, on screen 2.1, choose the option “Use my current theme search template”: your theme will then display results returned by WPSOLR as usual.

    Just add the WPSOLR facets widget to your archive pages sidebar.

    mhuntley
    Participant
    11 months, 1 week ago #32836

    Thanks for the response.

    Can you please advise what action I should take if my theme does not support a sidebar?

    wpsolr
    Keymaster
    11 months, 1 week ago #32838

    I suggest to ask your theme’s support.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.