Different options to sort

  • O-O
    Participant
    2 years, 12 months ago #17619

    Hi there,

    I checked with my provider and the PHP errors are now fixed. But it still seems like the sort option is not working.

    wpsolr
    Keymaster
    2 years, 12 months ago #17620

    I still cannot see any WPSOLR filters on your site right now.

    O-O
    Participant
    2 years, 12 months ago #17621

    Yes I also made a topic for it. That our filters disappeared.

    After the restore, the filters seem to not show anymore on the website. We have already re-indexed but this did not solve the problem. But by our server they say there are no errors. And everything looked fine. Could it be some settings are changed. Or what can we check to see if we can get the filters back

    https://ibb.co/b7HMStd

    wpsolr
    Keymaster
    2 years, 12 months ago #17622

    What new errors do you see now in debug.log?

    wpsolr
    Keymaster
    2 years, 12 months ago #17623

    You can also try to create a new index. We had had a similar issue when you started evaluating WPSOLR, if I remember.

    O-O
    Participant
    2 years, 12 months ago #17624

    Yes we indeed had the same issue that the filters where not showing. We tried to create a new index but that was not working.

    O-O
    Participant
    2 years, 12 months ago #17625

    And we can not see any new errors.

    wpsolr
    Keymaster
    2 years, 12 months ago #17626

    There should be errors, as mentioned in the chrome js console:
    “WPSOLR PRO : an error prevented the search engine query to be executed. To prevent empty results, the default WordPress query is used instead. Please check the error details in your debug.log file.”

    O-O
    Participant
    2 years, 12 months ago #17627

    Ahh yes I found this one in the chrome js console:

    VM3551 winkel:3 WPSOLR PRO : an error prevented the search engine query to be executed. To prevent empty results, the default WordPress query is used instead. Please check the error details in your debug.log file. See https://codex.wordpress.org/Debugging_in_WordPress.

    But I meant I do not see anything in the debug.log file > it keeps loading, and the server can not see the problem.

    wpsolr
    Keymaster
    2 years, 12 months ago #17628

    I created a new index, indexed a few products. And your filters are back!

    O-O
    Participant
    2 years, 12 months ago #17629

    Ohh Yes I see great thank you!.

    But now I see that we only have 300 products instead of 26866?

    wpsolr
    Keymaster
    2 years, 12 months ago #17630

    Yes, I stopped indexing at 300, just for testing.

    O-O
    Participant
    2 years, 12 months ago #17631

    It looks like we only see the adidas products

    O-O
    Participant
    2 years, 12 months ago #17632

    Ahh oke that explanes! But when I go to the index it looks like all is indexed and no more index is needed

    O-O
    Participant
    2 years, 12 months ago #17633

    We did the index again, and the products and filters are showing. Exept the sort function for the algoritm is still not working.

Viewing 15 posts - 16 through 30 (of 34 total)

You must be logged in to reply to this topic.