Clean Wordpress install, wpsolr doesn’t replace default search

  • Japhy
    Participant
    6 months, 3 weeks ago #37151

    Hi there,

    We are looking to implement semantic search both in our Drupal and WordPress projects. As for the latter, after some research I came across this plugin which looks really promising.

    So I fired up a wordpress docker instance, and a weaviate docker instance, see below. All seems to work fine, indexing etc, no problems. But the website itself seems to be using wp default search. i did check debugging in my browser but found no errors. I emptied the index to be sure, and yes still gave me the same results. I double checked: In step 2 I did pick the right new engine! Is there actaully I quikck way to make sure what engine is being used?

    I am using a clean wordpress install behind nginx proxy manager. Using generatepress theme, but same problem with default theme.

    I have no idea why this is happening. I would love to start using this if it delivers. Any ideas?

    
    version: '3.4'
    services:
      weaviate:
        image: semitechnologies/weaviate:1.22.1
        restart: on-failure:0
        ports:
         - "8083:8080"
        environment:
          QUERY_DEFAULTS_LIMIT: 20
          AUTHENTICATION_ANONYMOUS_ACCESS_ENABLED: 'true'
          PERSISTENCE_DATA_PATH: "./data"
          DEFAULT_VECTORIZER_MODULE: text2vec-transformers
          ENABLE_MODULES: text2vec-transformers
          TRANSFORMERS_INFERENCE_API: https://t2v-transformers:8080
          CLUSTER_HOSTNAME: 'node1'
      t2v-transformers:
        image: semitechnologies/transformers-inference:sentence-transformers-paraphrase-multilingual-MiniLM-L12-v2
        environment:
          ENABLE_CUDA: 0 # set to 1 to enable
          # NVIDIA_VISIBLE_DEVICES: all # enable if running with CUDA

    version: ‘3.3’

    services:
       wordpress:
         depends_on:
           - db
         image: wordpress:6.3.2-php8.2-apache
         container_name: wordpress_dev
         volumes:
           - /srv/wordpress_dev/wordpress_files:/var/www/html
           - /srv/wordpress_dev/custom/wordpress.ini:/usr/local/etc/php/conf.d/wordpress.ini 
         ports:
           - "86:80"
         restart: always
         environment: 
           WORDPRESS_DB_HOST: xxxxxx
           WORDPRESS_DB_USER: xxxxx
           WORDPRESS_DB_PASSWORD: xxxxxxx
    
       db:
         image: mysql:5.7
         container_name: wordpress_dev_db
         volumes:
           - /srv/wordpress_dev/db_data:/var/lib/mysql
         restart: always
         environment:
           MYSQL_ROOT_PASSWORD: xxxxxxx
           MYSQL_DATABASE: xxxxxxx
           MYSQL_USER: xxxxxxx
           MYSQL_PASSWORD: xxxxxx
    
    volumes:
        wordpress_files:
        db_data:
    • This topic was modified 6 months, 3 weeks ago by Japhy.
    wpsolr
    Keymaster
    6 months, 3 weeks ago #37153

    Did you select the “2.1 Search” screen options to replace your archives with WPSOLR (search, taxonomies, …)?

    Japhy
    Participant
    6 months, 3 weeks ago #37156
    wpsolr
    Keymaster
    6 months, 3 weeks ago #37157

    Is your search the standard WP archive search with url “/?s=” ?

    Or is it a custom search page brought by your theme?

    Japhy
    Participant
    6 months, 2 weeks ago #37166

    Yup, double checked but it shows .com/?s=test

    Japhy
    Participant
    6 months, 2 weeks ago #37167

    Wait what, I checked debugger again and now I do see this

    View post on imgur.com


    Would this have to do with my docker nginx setup?

    wpsolr
    Keymaster
    6 months, 2 weeks ago #37168

    You should see errors in your WP debug.log

    wpsolr
    Keymaster
    6 months, 2 weeks ago #37169

    You can active the Query monitor add-on

    Japhy
    Participant
    6 months, 2 weeks ago #37173

    That is very interesting, didn’t know that plugin. Looks okay although I don’t see wpsolr in the left panel like in your examples

    View post on imgur.com

    wpsolr
    Keymaster
    6 months, 2 weeks ago #37174

    Did you active the WP_DEBUG to check errors in debug.log?

    Japhy
    Participant
    6 months, 2 weeks ago #37175

    I am still working on it haha It’s not enabled by default in my docker compose setup it seems. So I enabled it in my docker compose file but somehow the debug.log still doesn’t show in wp-content. Will have to examine further but now my diner is waiting. Will report back though! Thanks so far!

    Japhy
    Participant
    6 months, 2 weeks ago #37176

    I get this message whatever it means 🙂

    `Deprecated: Implicit conversion from float 1698859233.707014 to int loses precision in /var/www/html/wp-content/plugins/wpsolr-free/wpsolr/core/classes/engines/class-wpsolr-abstractengineclient-root.php on line 398′

    Japhy
    Participant
    6 months, 2 weeks ago #37186

    Is this something that could cause the issue @wpsolr?

    Japhy
    Participant
    6 months, 2 weeks ago #37187

    I just updated to 23.5, same issue, same notification in debugger. But now i get this warning: Warning: Undefined variable $ajax_delay_ms in /var/www/html/wp-content/plugins/wpsolr-free/wpsolr/core/wpsolr_include.inc.php on line 714

    wpsolr
    Keymaster
    6 months, 2 weeks ago #37188

    Deprecated: Implicit conversion from float 1698859233.707014 to int loses precision in /var/www/html/wp-content/plugins/wpsolr-free/wpsolr/core/classes/engines/class-wpsolr-abstractengineclient-root.php on line 398

    Warning: Undefined variable $ajax_delay_ms in /var/www/html/wp-content/plugins/wpsolr-free/wpsolr/core/wpsolr_include.inc.php on line 714

    This is just a warning. Do you see other errors in debug.log?

Viewing 15 posts - 1 through 15 (of 20 total)

You must be logged in to reply to this topic.