RunExecutableListener is deprecated and disabled by default for security reasons

  • jameskira
    Participant
    # 5 months, 3 weeks ago

    So I am having issue testing solr, specifically clicking “Index selected post types in index ‘Index Name'”

    Solr HTTP error: OK (401) {"responseHeader":{"status":401,"QTime":1309},"error":{"metadata":["error-class","org.apache.solr.common.SolrException","root-error-class","org.apache.solr.common.SolrException"],"msg":"RunExecutableListener is deprecated and disabled by default for security reasons. Legacy applications still using it must explicitely pass '-Dsolr.enableRunExecutableListener=true' to the Solr command line. Be aware that you should really disable API-based config editing at the same time, using '-Ddisable.configEdit=true'!","code":401}}

    Can you give a suggestion to fix this? Im also wondering if we have to click “Index selected post types in index ‘Index Name'” to index the website data?

    wpsolr
    Keymaster
    # 5 months, 3 weeks ago

    Hi,

    RunExecutableListener is disabled in WPSOLR’s solrconfig.xml files, as it should. It seems you are updating an index not created from WPSOLR’s configuration files. Please create another index from WPSOLR: https://www.wpsolr.com/guide/configuration-step-by-step-schematic/configure-your-indexes/connect-to-an-apache-solr-index/

    Im also wondering if we have to click “Index selected post types in index ‘Index Name’” to index the website data?

    Yes indeed, you have to, once your index is created from WPSOLR.

    jameskira
    Participant
    # 5 months, 3 weeks ago

    Hi,

    Just a clarification on indexing, isn’t this done automatically if there are product changes on the site? Or if there are changes to the products indexing is NOT done automatically?

    wpsolr
    Keymaster
    # 5 months, 3 weeks ago

    It is done automatically, whenever a post type is created/updated/trashed. Unless you check the “Do not index in real-time” option in screen 2.2

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.