MyListing extension on staging server and Shield Pro compatibility issues?

  • dogfuriendly-john
    Participant
    1 month, 3 weeks ago #31287

    Hi.

    I’m trying to get WPSOLR Pro working on our staging server for evaluation purposes, although it doesn’t appear to be possible to activate the MyListing theme extension without the paid version – is this supposed to be the case on a staging.xxx domain?

    Additionally, WPSOLR doesn’t appear to be compatible with Shield Pro (https://getshieldsecurity.com/) – the following error is thrown when I attempt to activate WPSOLR…

    …PHP message: PHP Fatal error: Declaration of FernleafSystems\Wordpress\Plugin\Shield\Modules\AuditTrail\Lib\LogHandlers\LocalDbWriter::write(array $record) must be compatible with Monolog\Handler\AbstractProcessingHandler::write(array $record): void in /…STAGING_SERVER_FQDN…/httpdocs/wp-content/plugins/wp-simple-firewall/src/lib/src/Modules/AuditTrail/Lib/LogHandlers/LocalDbWriter.php on line 26" while reading response header from upstream…

    Is this an issue you’re aware of?

    Thanks in advance.

    Regards,
    John Parker.

    wpsolr
    Keymaster
    1 month, 3 weeks ago #31289

    Indeed, but we will make add-ons available to the dev/test/staging trial environments on the next 22.4 release.

    Regarding the fatal error, I cannot see a link with WPSOLR in your message text. WPSOLR does not bring the file LocalDbWriter.php.

    dogfuriendly-john
    Participant
    1 month, 3 weeks ago #31290

    Hi.

    Thanks for the speedy response – do you have a sense of when the 22.4 release is likely to be? (Are there any beta versions available for test?)

    In terms of the error, we’ve heard back from the Shield Pro devs…

    It appears to be Shield generating the error, but as you’ve discovered, it’s both plugins together causing the problem. We each have a different, incompatible, version of the PHP monolog library distributed with our plugin. Our plugin throws the error just by the timing of the included library.

    We suspect that unfortunately they have chosen a version of the library that is only compatible with PHP 7.2+.

    There’s nothing we can do to mitigate this error – except perhaps upgrade our library version. Unfortunately this isn’t practical because the newest version of Monolog is only compatible with PHP > 8.1. We support PHP 7.0+ so we can’t make that switch.

    You may want to reach out WPSOLR author and let them know about this error and ask them if they’d consider using an older version of the library.

    Is such a downgrade feasible from your perspective, or are the security or functionality issues that would prohibit this?

    THanks again.

    Regards,
    John Parker.

    wpsolr
    Keymaster
    1 month, 3 weeks ago #31291

    WPSOLR 22.4 will not be there soon, as it take time to bring and test 4 new recommender APIs.

    Monolog being brought from composer dependencies, we cannot restrict it.

    PHP 7/PHP 8

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.