Fatal errorTrying to create too many buckets

  • 9 months, 3 weeks ago #34837

    Hi I am getting this error , on newly indexed taxonomy pages, not an issue with all archive pages, but only recently indexed one’s. Can you tell the reason for this error, why its happening with new taxonomy archive pages.

    Fatal error: Uncaught Exception: {"error":{"root_cause":[{"type":"too_many_buckets_exception","reason":"Trying to create too many buckets. Must be less than or equal to: [10000] but was [10001]. This limit can be set by changing the [search.max_buckets] cluster level setting.","max_buckets":10000}],"type":"search_phase_execution_exception","reason":"all shards failed","phase":"query","grouped":true,"failed_shards":[{"shard":0,"index":"test_index","node":"a8xpkVcrRwSVMQ4H1196lQ","reason":{"type":"too_many_buckets_exception","reason":"Trying to create too many buckets. Must be less than or equal to: [10000] but was [10001]. This limit can be set by changing the [search.max_buckets] cluster level setting.","max_buckets":10000}}]},"status":503}
    in /code/wp-content/plugins/wpsolr-pro/wpsolr/core/vendor/elasticsearch/elasticsearch/src/Elasticsearch/Connections/Connection.php on line 726
    wpsolr
    Keymaster
    9 months, 3 weeks ago #34840

    Try to increase https://www.elastic.co/guide/en/elasticsearch/reference/current/search-settings.html#search-settings-max-buckets, then you can analyse the Elasticsearch query result with WPSOLR’s Query monitor add-on.

    9 months, 3 weeks ago #34956

    Okay, after increasing search max buckets, its working fine.

    wpsolr
    Keymaster
    9 months, 3 weeks ago #34970

    🙂

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.