Error when indexing articles

  • scumunna
    Participant
    2 years, 3 months ago #21618

    Hi Patrice!
    I’m experiencing a new error when I try to index new articles. I’ve attached a link to a screenshot for you.

    https://ibb.co/rF4Cj57

    Thanks!

    Stephen

    wpsolr
    Keymaster
    2 years, 3 months ago #21620

    Your Elasticsearch index is over used.

    To prevent the message in Kibana:

    PUT /_all/_settings
    {
      "index.blocks.read_only_allow_delete": null
    }

    Or with ssh command line on your server directly:
    curl -XPUT "https://localhost:9200/_all/_settings" -H 'Content-Type: application/json' -d'{ "index.blocks.read_only_allow_delete": null}'

    scumunna
    Participant
    2 years, 2 months ago #21717

    Thank you, Patrice! It worked.
    Best,
    Stephen

    scmsteve
    Participant
    2 years, 2 months ago #21875

    Is there an explanation of what this does and why it is helpful? And what cases it applies to or resolves?

    wpsolr
    Keymaster
    2 years, 2 months ago #21884

    This flag is raised by Elasticsearch when disk space is getting close to 100%: https://www.elastic.co/guide/en/elasticsearch/reference/7.9/modules-cluster.html#cluster-routing-flood-stage
    But I noticed the index can be in read-only mode even if the disk has plenty of free space. Resetting the index.blocks.read_only_allow_delete flag is then a workaround.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.