archive-product page missing images with WP All Import

  • rvs
    Participant
    3 years, 1 month ago #14782

    Hi,

    We have imported new products.

    When i go to the shop page (archive-product) i see that all products are there.
    But all new products are divided on new multiple pages 4 per page and than 8 per page and than 4 per page and so on. Till i reach the page of existing products, from there it’s all ok.

    page 1 has 4 prods
    page 2 has 8 prods
    page 3 has 4 prods
    ,,
    ,,
    ,,
    page 15 has 32 prods (correct, 32 per page is defined)

    It only appears on the archive-product.php with the new NEW sorting active.

    We have a lot of pages pagination goes up to 453 pages.
    Maybe it has something to do with resources.

    I have disabled all plugins and tested storefront theme. Issue still there.

    When i DISABLE wpsolr plugin, all good. First page has 32 products. For all sorting options.

    wpsolr
    Keymaster
    3 years, 1 month ago #14783

    After importing, your index is no more synchronized, which can cause that kind of issues.

    I wrote a detailed guide an all the strategies you can use to import data and keep your index synchronized:

    Best practice to Import data in WordPress & Elasticsearch

    rvs
    Participant
    3 years, 1 month ago #14784

    I imported up to 100 new products.
    What do you suggest to do.

    Should i disable real time indexing for such a small import?
    Do i need to index manual each time?

    wpsolr
    Keymaster
    3 years, 1 month ago #14785

    For 100, real-time should be fine.

    rvs
    Participant
    3 years, 1 month ago #14786

    Ok so why do i have this weird issue?

    wpsolr
    Keymaster
    3 years, 1 month ago #14787

    If you’re using WP All Import, you’ll need to activate our add-on.

    Because WP All import deletes products with a SQL command, rather than with the WordPress posts api. Which means that deletes are not detected by WPSOLR (no posts deletion hook triggered), which cannot update the index in real-time.

    The WP All import add-on should fix that issue.

    rvs
    Participant
    3 years, 1 month ago #14788

    So

    1. activate add on
    2. rebuild new index to have the isue fixed
    3. new imports with 100 prod real time indexing should go fine

    Correct?

    wpsolr
    Keymaster
    3 years, 1 month ago #14789

    Looks good.

    rvs
    Participant
    3 years, 1 month ago #14790

    Ok i have searched for add on information, but i cant find a detailed topic.
    Only a bunch of topics, nothing in there.

    Do you have a link for me?

    wpsolr
    Keymaster
    3 years, 1 month ago #14791

    You can find it in the “Extensions” horizontal tab inside the plugin admin.

    Image wpsolr-screenshot-wp-all-import-menu.png of

    rvs
    Participant
    3 years, 1 month ago #14795

    all ok now thnx

    rvs
    Participant
    2 years, 11 months ago #15876

    Hi

    When we add new products the indexing does not sync.
    I did not enable the option “stop real time indexing” in the admin.

    So why is my index not syncing?

    wpsolr
    Keymaster
    2 years, 11 months ago #15879

    Do you see errors in debug.log?

    rvs
    Participant
    2 years, 11 months ago #15892

    [Mon Dec 16 17:38:43.466180 2019] [proxy_fcgi:error] [pid 31280] [client 127.0.0.1:47188] AH01071: Got error ‘PHP message: WPSOLR message: {“error”:{“root_cause”:[{“type”:”query_phase_execution_exception”,”reason”:”Result window is too large, from + size must be less than or equal to: [10000] but was [12352]. See the scroll api for a more efficient way to request large data sets. This limit can be set by changing the [index.max_result_window] index level setting.”}],”type”:”search_phase_execution_exception”,”reason”:”all shards failed”,”phase”:”query”,”grouped”:true,”failed_shards”:[{“shard”:0,”index”:”XXXXXX”,”node”:”XXXXXXXX”,”reason”:{“type”:”query_phase_execution_exception”,”reason”:”Result window is too large, from + size must be less than or equal to: [10000] but was [12352]. See the scroll api for a more efficient way to request large data sets. This limit can be set by changing the [index.max_result_window] index level setting.”}}]},”status”:500}PHP message: WPSOLR trace: #0 ……………..

    wpsolr
    Keymaster
    2 years, 11 months ago #15893

    By default, Elasticsearch can scroll 10,000 results, hence this error.

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.