Allow to exclude certain facet value from taxonomy/attributes/categories filters

  • Murat
    Participant
    1 year, 11 months ago #23176

    some times when dealing with huge product catalogues – like more than 50,000 … many attributes are not well maintained in the data source — and left uncategorized.
    it would be very useful to allow us to configure WPSOLR to exclude the display of checkboxes for certain odd filters like “uncategorized” … or whatsoever … which would let the site visitor always focused on the clean data.
    for example, annasta filters and woobeewoo does have such feature.

    wpsolr
    Keymaster
    1 year, 11 months ago #23181

    For performance reasons, it would be better to prevent indexing of unwanted values.
    I could add an exclusion regex on each field of screen 2.2?

    Murat
    Participant
    1 year, 11 months ago #23214

    i think it is better not to prevent the indexing – as this should not be affecting the global search
    but only intention is to present a sub-set of filters per web-site preference.

    wpsolr
    Keymaster
    1 year, 10 months ago #23459

    Fix available on https://trello.com/c/i5ey4TWX/125-exclude-certain-facet-values
    A new checkbox “Hide” is available on each facet item in screen 2.4

    Murat
    Participant
    1 year, 10 months ago #23471

    Thanks for the update – i will be testing that and reporting back.

    wpsolr
    Keymaster
    prakashreddy.imduri
    Participant
    6 months, 1 week ago #29712

    Hi,
    I’ve installed WPSOLR PRO 22.6 and also 22.2, I could not see “Hide” option in screen 2.4,
    Can you please let me know is it part of latest releases, we need to hide few values in facet search filters.

    Thanks
    Prakash

    wpsolr
    Keymaster
    6 months, 1 week ago #29714

    On WPSOLR 22.2, click on you filter’s button “Override each item label” to open the section containing the “Hide” option.
    The “hide” is available on checkbox or listbox layouts.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.