WPsolr integration fails

  • izzy
    Participant
    # 11 months, 1 week ago

    After connecting the WPsolr plugin to Opensolr using my email and the API key, I still don’t see the newly created index in the plugin interface; even it does appear in the Opensolr dashboard. Instead, If I’m going back to tab #0 (connect your indexes), it doesn’t seem to be connected at all; instead, I need to reconnect.

    wpsolr
    Keymaster
    # 11 months, 1 week ago

    You have created your Opensolr index. You now need to select it in screen 2.1 as you search index.

    izzy
    Participant
    # 11 months, 1 week ago

    I have not. It was created automatically by the plugin. The problem is that I don’t see the newly created index in that select box even thou I do see it on Opensolr dashboard.

    wpsolr
    Keymaster
    # 11 months, 1 week ago

    Can you try with a new index (and check your debug.log errors)?

    izzy
    Participant
    # 11 months, 1 week ago
    wpsolr
    Keymaster
    # 11 months, 1 week ago

    In the video, we can see that the “Index loading …” status never ends.
    Do you see javascript errors in the chrome inspector console when creating the index?

    izzy
    Participant
    wpsolr
    Keymaster
    # 11 months, 1 week ago

    It could be a PHP timeout (30 seconds?) during the Ajax call to your WordPress.

    Can you check your “network” inspection and look for the admin-ajax.php results?

    izzy
    Participant
    wpsolr
    Keymaster
    # 11 months, 1 week ago

    Most of them are standard WP ajax call.
    Try to find WPSOLR’s call.

    izzy
    Participant
    wpsolr
    Keymaster
    # 11 months, 1 week ago

    Try to increase your PHP timeout.

    izzy
    Participant
    # 11 months, 1 week ago

    It’s on 300 now. Do you think that we need more than that? I never encountered any issue…

    wpsolr
    Keymaster
    # 11 months, 1 week ago

    Please try with a Key and a Secret/Password on the index form.

    wpsolr
    Keymaster
    # 11 months, 1 week ago

    To prevent this issue happening again, Opensolr secret/pwd are made mandatory in next release: https://trello.com/c/sWc4Za1y/127-fix-opensolr-error-while-creating-an-index-with-empty-key-secret

Viewing 15 posts - 1 through 15 (of 17 total)

You must be logged in to reply to this topic.