WC 4.3.3. SORT no longer working. WC 4.4.1 now breaks Categories as well

  • OEM
    Participant
    # 1 year, 5 months ago

    Using WordPress 5.5 + Woocommerce 4.3.3
    – Woocommerce sort list no longer working. Always shows most relevant items regardless of option made which I believe is Woocommerce default. Turning off WPSOLR Sort in woocommerce theme does not fix the issue, nor does changing any of the options under the WPSOLR sort options (1st sort, 2nd sort and any of the additional sort options.. no effect). Not sure what Woocommerce update did this, I only noticed it now. Could have been present as well in previous verstions (4.3.2.. 4.3.1… 4.3.0)

    Tried upgrading today to Woocommerce 4.4.1 for testing. It breaks the category’s. Products are no longer shown. On search, products are shown but noticed that the Woocommerce product count and sort list is now completely missing. So this is even worse 🙂 . Reverted back to 4.3.3.

    wpsolr
    Keymaster
    OEM
    Participant
    # 1 year, 5 months ago

    Ok, i did that. All seems ok but now the filters are acting strange.

    After a couple filters used, it ends up saying “no products encountered” and the page becomes empty and the facets gone.

    OEM
    Participant
    # 1 year, 5 months ago

    Follow up, this happens under categories that was fixed with the above update.
    Reverted back now to 4.3.3 as it is a live site.

    wpsolr
    Keymaster
    # 1 year, 5 months ago

    I’m fixing the categories too.
    This is madness: WP 5.5, PHP 7.4, and WC 4.4.1, they all broke something. Never seen that before.

    OEM
    Participant
    # 1 year, 5 months ago

    Ok, no problem. I have no rush to update to latest Woocommerce. I can live with the Sort problem for the next few weeks.

    Although, as an add on, if you recall I had problems with facets that contained the caracter ”
    Maybe fix that issue as well together with the present issues 🙂 See topic below.

    Quotation mark character generating problems on filters

    wpsolr
    Keymaster
    # 1 year, 5 months ago

    My tests are working fine with WooCommerce & Elasticsearch categories too.

    Did you install the latest WPSOLR fix?

    OEM
    Participant
    # 1 year, 5 months ago

    Yes, I installed the latest.
    It breaks the facets. It seems to work at first, but as more facets get selected for filtering, it ends up in error. So to test, you would have to have many variations / products. Testing a small amount of products and facets, it probably seem to work ok. As I said, only after going through a few of the facets that this problem starts to show up.

    wpsolr
    Keymaster
    # 1 year, 5 months ago

    What “it ends up in error” is exactly?

    OEM
    Participant
    # 1 year, 5 months ago

    You get the “no product found” default woocommerce message as if you searched for a product that does not exist.

    Products and facets dissapear. Must reload the page.

    wpsolr
    Keymaster
    # 1 year, 5 months ago

    With Elasticsearch or Solr?

    OEM
    Participant
    # 1 year, 5 months ago

    SOLR

    wpsolr
    Keymaster
    # 1 year, 5 months ago
Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.