View more issues after use of filters

  • O-O
    Participant
    2 years, 9 months ago #17658

    Hi,

    When I go to our webshop and use some filters I am facing some difficulties with the view more button.

    For example when I filter on categorie on dresses “dames” > “dames kleding” > “dames jurken” > “dames feestjurken” we have 7 products. but when I push the view more button my filters dissapear in the url and I go back to the “dames kleding” categorie.

    Another example: When I filter on yellow and adidas I get 15 results. And when I push the view more option I get more products. For example brown hummel shoes.

    Can you please tell me why this is happening and if we can fix this?

    Thank you!

    wpsolr
    Keymaster
    2 years, 9 months ago #17659

    Where does the “View More” feature come from?

    O-O
    Participant
    2 years, 9 months ago #17663

    The view more button is something in the Flatsome Theme we are using.

    wpsolr
    Keymaster
    2 years, 9 months ago #17664

    Thanks. I’m checking the Flatsome “View more” integration to WPSOLR.

    wpsolr
    Keymaster
    2 years, 9 months ago #17665

    I could not find the “View more” settings in my Flatsome theme.

    wpsolr
    Keymaster
    2 years, 9 months ago #17666

    Found it: “Infinite scroll”

    wpsolr
    Keymaster
    2 years, 9 months ago #17667

    Bad news, unfortunately: WPSOLR filters Ajax is currently incompatible with Flatsome’s Infinitescroll Ajax.

    More precisely:
    1) A click on a any WPSOLR filter calls an Ajax function that rewrites the container results
    2) A click on the Flatsome “View More” retrieves the “Next button link” and calls an Ajax function from the container results navigation bar (hidden, but still present)

    The problem is that Flatsome seems to use the first navigation bar “Next button link”, the one present before the WPSOLR filter’s click.

    But if you click on a WPSOLR filter, and refresh the page (F5), then the “View more” works. Because then the Flatsome’s javascript code is reinitialised and uses the new “Next button link”.

    Usually, I solve this issue by reinitialising the Flatsome’s library after each filter click. But here, it simply causes a javascript error. And I cannot debug further, because Flatsome uses a minified external infiniteScroll library.

    So, now, here are two options:
    1) Deactivate the WPSOLR filters Ajax (in the WPSOLR “Theme” extension)
    2) Forward this diagnostic to Flatsome’s support team. Perhaps they have a solution that I can implement in WPSOLR.

    O-O
    Participant
    2 years, 9 months ago #17744

    Hi Thanks for the response.

    What do you mean by deactivate the WPSOLR filters Ajax? When I check our active extensions We only have ACF, Premium, Theme and WooCommerce Active.

    wpsolr
    Keymaster
    2 years, 9 months ago #17753

    In screen 2.1, you can select “My theme with Ajax” or “My theme without Ajax”. Choose the 2nd option in the drop-down list.

    O-O
    Participant
    2 years, 9 months ago #17930

    Looks like this fixed the problem, Thanks!

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.