shop page does not display all products

Tagged:
  • Murat
    Participant
    1 year, 10 months ago #23507

    visiting my shop page i see at the top::
    “Showing 1–100 of 10000 results” and pages up to 100 pages.

    As I have around 70,000 products fully indexed (and yes I have rebuild the indices manually to rule out any corrupt index issue) using wpsolr 22.0 + elastic search
    so it should rather be showing
    “Showing 1–700 of 70000 results” and pages up to 100 pages….
    is there a cap of 100 pages –?

    wpsolr
    Keymaster
    1 year, 10 months ago #23508

    The detailed tutorial to fix the 10,000 results in Elasticsearch is on Fix Elasticsearch error “Result window is too large”

    Murat
    Participant
    1 year, 10 months ago #23511

    Thanks a lot
    I have dug further and resorted to making that permanent by adding this line to the “elasticseach.yml”

    index.max_result_window: 1000000

    Murat
    Participant
    1 year, 10 months ago #23513

    I am correcting my self – please ignore or (delete) my last erroneous response about putting “index.max_result_window: 1000000” in the elasticsearch.yml … as it turned out this parameter does not work starting in recent versions of elastic search engine…

    I have followed your guide – but had to fix the quotation strings as curl was giving many errors in ACE string conversions….
    Therefore, finally — this is the CLEAN one AS-IS – which worked.

    ======================
    curl -X PUT ‘https://127.0.0.1:9200/sharif/_settings’ -H ‘Content-Type: application/json’ -d ‘{ “index” : { “max_result_window” : 1000000 } }’
    =======================

    Murat
    Participant
    1 year, 10 months ago #23594

    currently i have ended up stopping using elastic search, and have switched to apache SOLR – works like a charm.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.