Quotation mark character generating problems on filters

  • OEM
    Participant
    2 years, 7 months ago #19818

    Hello!

    Attributes with values such as 15″, 16″, 17″, etc., have problem when using the filter.

    When trying to use the filter with these types of values, page will simply reload and hang.

    As you recall, in our previous support session with the indexing that was failing, which we then found out that it was due to the new PHP version (7.4.5) and was resolved by downgrading the PHP version, we saw error messages show up on SOLR log about the character ” (quotation mark).

    wpsolr
    Keymaster
    2 years, 3 months ago #21601

    Please check the fix on quote characters and Solr made for https://www.wpsolr.com/forums/topic/woocommerce-archive-pages-not-showing-products/page/3/

    wpsolr
    Keymaster
    OEM
    Participant
    2 years, 1 month ago #22335

    Hello, I tried the new plugin from the link above for testing as I arranged some time today to finally test it out.

    What was Fixed:
    – Quotation marks fixed, now I can use filters that contain quotation marks
    – Default Woocommerce sort using WPSOLR fixed

    What got broken:
    – Selecting 3 or more facet options / filters started to display problems with unrelated results of products being displayed
    – Ion range slider now has a conflict, does not work, reloads page and stalls the page from loading.

    Plugin was updated solely, no other updates were made. Woocommerce and WordPress versions were maintained (WC 4.3.3 / WP 5.5.1 / PHP 7.3.23)

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.