Problems creating first Solr index

  • robpl1
    Participant
    # 1 year, 6 months ago

    I’ve downloaded WPSolr Pro and have installed and activated it. I’ve also got an instance of Apache Solr installed and running. This is all on a VM on an internal IP address where I’m using real world data for testing, Solr 8.7.0. and your plugin v22.0
    I’m trying to connect the indexes now but am running into trouble. I obtained the index path from the Solr Dashboard and entered into the config screen at Tab 0 and then entered the rest of the details required. I had to create most of the paths specified by the plugin such as configsets and the index/conf under that. I then ran the curl script (curl -L -o index.zip https://www.dropbox.com/ etc) and then tried to save the configuration. This failed with the error message “This index name already exist.”. Is there anything I’m doing wrong here or missing out?

    wpsolr
    Keymaster
    # 1 year, 6 months ago

    I obtained the index path from the Solr Dashboard and entered into the config screen at Tab 0

    WPSOLR need to create the index from scratch.
    1) Delete this index from the Solr dashboard
    2) Then proceed on creating the index from WPSOLR as you did before

    robpl1
    Participant
    # 1 year, 6 months ago

    But that’s what I’ve done. starting again with nothing showing in the Solr Core Amin, I tried again creating a new index, called chimes, and didn’t put anything in Solr. in the plugin I entered the server details and gave it a path to use. At this point there’s nothing showing in server core admin and the only extra directory I’ve created is /var/solr/data/configsets. I click the button at the bottom and get all the instructions on what to do then click the button at the bottom again. This returns
    Solr HTTP error: OK (404)
    HTTP ERROR 404 Not Found
    URI: /var/solr/data/chimes/admin/ping
    STATUS: 404
    MESSAGE: Not Found
    SERVLET: –

    So I check the path and they’re not there. So I create them and get “Inde3x already exists” message. So I delete everything and try again this time making sure the directories existed before I clicked the button the second time. I got exactly the same 404 message as before and clisking the button a 3td time brought up the “Index Exists” message.

    wpsolr
    Keymaster
    # 1 year, 6 months ago

    a) Something in Solr logs?
    b) Is it Solr or SolrCloud?
    c) What is the Solr path you’ve set in WPSOLR screen?

    robpl1
    Participant
    # 1 year, 6 months ago

    I’m using this path for the index
    /var/solr/data/chimes

    And these are the log entries
    15/12/2020, 09:59:21
    WARN false
    x:chimes
    Suggester
    Loading stored lookup data failed
    15/12/2020, 09:59:21
    ERROR false
    x:chimes
    SpellCheckComponent
    Exception in reloading spell check index for spellchecker: suggest

    wpsolr
    Keymaster
    # 1 year, 6 months ago

    The “path” in WPSOLR should be “/solr/chimes”

    robpl1
    Participant
    # 1 year, 6 months ago

    Just in case there was a version problem I removed Solr 8.7 and installed 7.4. Same problem! 404 can’t find ../admin/ping even though its right there.
    There are a couple of different log messages though
    15/12/2020, 12:09:16
    WARN false
    x:chimes
    Config
    You should not use LATEST as luceneMatchVersion property: if you use this setting,​ and then Solr upgrades to a newer release of Lucene,​ sizable changes may happen. If precise back compatibility is important then you should instead explicitly specify an actual Lucene version.
    15/12/2020, 12:09:16
    WARN false
    AND
    15/12/2020, 12:09:16
    WARN true
    x:chimes
    SolrResourceLoader
    Solr loaded a deprecated plugin/analysis class [solr.LatLonType]. Please consult documentation how to replace it accordingly.

    There are a few others on the plugin type

    wpsolr
    Keymaster
    # 1 year, 6 months ago

    Yes, WPSOLR was tested on Solr 8.6

    Did you install the binaries or the sources?

    robpl1
    Participant
    # 1 year, 6 months ago

    The binaries from solr-8.7.0.tgz

    wpsolr
    Keymaster
    # 1 year, 6 months ago

    Can you show here the WPSOLR index screenshot?

    robpl1
    Participant
    # 1 year, 6 months ago

    This is what I was doing. Solr image
    Unfortunately an update (not sure if it was to my VM or Ubuntu) has left me unable to properly use the Solr interface. None of the links work. I suspect the VM software (Fusion on Mac) since the problem occurs in snapshots taken before the update.

    wpsolr
    Keymaster
    # 1 year, 6 months ago

    The “path” in WPSOLR should be “/solr/chimes”

    robpl1
    Participant
    # 1 year, 6 months ago

    Thanks very much. That seems to be working, at least in so far is it created the index. Now though there are a few other problems. Although the index seems to be loaded, according to tab zero, it may not be from looking at tab 2 heading. Indexed?

    robpl1
    Participant
    # 1 year, 6 months ago

    Finally there were a few error messages in the Solr log file that might be of interest.
    Error log

    wpsolr
    Keymaster
    # 1 year, 6 months ago

    You now need to follow all tabs one after the other, including tab 2.

Viewing 15 posts - 1 through 15 (of 19 total)

You must be logged in to reply to this topic.