only products show in search results

  • Bodav
    Participant
    # 2 months, 1 week ago

    hi, i have set in Replace front-end archives in 2.1 to replace: search, home\blog, categories, tags, post types.
    but only products appear in search on frontend. using flatsome theme

    thank you !

    wpsolr
    Keymaster
    # 2 months, 1 week ago

    Can you give me an example?

    Bodav
    Participant
    # 2 months, 1 week ago

    https://snipboard.io/s5Lpfm.jpg
    any search which if not for products returns nothing ( i am searching for a post in this example, exact name)

    Bodav
    Participant
    # 2 months, 1 week ago

    also sent you an issue on trello, dont think its related here

    wpsolr
    Keymaster
    # 2 months, 1 week ago

    The WooCommerce stock visibility filter is applied to all post types, rather than on products only.

    I’m currently testing a fix.

    Bodav
    Participant
    # 2 months, 1 week ago

    is this also related to coupons not showing?

    wpsolr
    Keymaster
    # 2 months, 1 week ago

    I do not think so, but we’ll be sure after the fix.

    wpsolr
    Keymaster
    # 2 months, 1 week ago

    Please replace your current WPSOLR version with this release:
    https://trello.com/c/22LpaiA8/178-fix-woocommerce-showing-only-products-on-all-archives-when-stock-visibility-is-active

    The release includes the following fixes/improvements:
    – Fix WooCommerce add-on showing products only on all archives when stock visibility is active

    Bodav
    Participant
    # 2 months, 1 week ago

    its still not working for me
    do i need to set something anywhere else than here? https://snipboard.io/NLYdzB.jpg

    Bodav
    Participant
    # 2 months, 1 week ago

    sorry i needed to turn it on on flatsome settings
    now its fine

    wpsolr
    Keymaster
    # 2 months, 1 week ago

    And for your coupons admin search?

    Bodav
    Participant
    # 2 months, 1 week ago

    nope. no matter what, they do not appear

    wpsolr
    Keymaster
    # 2 months, 1 week ago

    They look fine on staging.
    Which flatsome settings did you change?

    Bodav
    Participant
    # 2 months, 1 week ago

    they did not work on staging this morning also.
    they sometimes do work, but on live site as of now, they are not working for few hours.
    on staging it seems they are not pulled from elastic as they are very slow compared to orders for example
    i think its related to hebrew..

    Bodav
    Participant
    # 2 months, 1 week ago

    i see that some settings on wpsolr staging are different than the live one, for example those values
    https://snipboard.io/CzdHwm.jpg

Viewing 15 posts - 1 through 15 (of 32 total)

You must be logged in to reply to this topic.