Incorrect results with Algolia

  • memphdutch
    Participant
    # 1 year, 10 months ago

    Hi,

    Yesterday I upgraded my install to this version, so that I could get facets to display not just on the search results page but also an archive page. https://www.wpsolr.com/forums/topic/woocommerce-archive-pages-not-showing-products/page/3/#post-21562

    The facets are displaying correctly, however the search results are now incorrect. No matter what I put in my search bar, it returns every single post in my index. For example, if I type in “joy,” it gives me a page that says “search results for: joy” but shows every item in my index. I am not sure if I checked an incorrect settings box or something. It was working correctly prior to yesterday.

    If I log directly into Algolia.com and try my search, it works correctly, so I know the problem isn’t the Algolia index itself. If I go to 2.1 “replace front-end archives” and uncheck the checkbox for search, it shows me results from WordPress’ internal search engine with no sidebar filters. So I recheck the box and get the filters back but get the bad results. So my problem is in WP Solr somewhere. Is this a problem with the release, or did I do something incorrectly in the settings?

    memphdutch
    Participant
    # 1 year, 10 months ago

    Any thoughts on this? My search was working but now has been broken.

    wpsolr
    Keymaster
    # 1 year, 10 months ago

    Did you find errors in your debug.log?

    wpsolr
    Keymaster
    # 1 year, 10 months ago

    Here is the fix for your Algolia empty keywords:
    https://www.dropbox.com/s/wpsomlmwdldq1vt/wpsolr-pro-wp5.5-php7.4-3.zip?dl=0

    memphdutch
    Participant
    # 1 year, 10 months ago

    That fixed it. Thanks.

    wpsolr
    Keymaster
Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.