Impossible to index PDF larger than 50MB

  • AlaplayaW
    Participant
    # 1 year, 5 months ago

    Hi,
    The upload limit on my WordPress config and local server is about 300MB.
    Everything work fine except if I import a PDF file larger than 50MB, the import to WordPress is fine but the indexing with WPSOLR & ES is not done.

    Error:
    Error type E_ERROR, lign 607 in file /Users/peryne/Local Sites/rmtwp/app/public/wp-content/plugins/wpsolr-pro/wpsolr/core/vendor/elasticsearch/elasticsearch/src/Elasticsearch/Connections/Connection.php.
    Error Message : Allowed memory size of 268435456 bytes exhausted (tried to allocate 71570392 bytes)

    How to fix that?
    Thanks

    wpsolr
    Keymaster
    # 1 year, 5 months ago
    AlaplayaW
    Participant
    # 1 year, 5 months ago

    I did it, and clear my browser cache and re-load my website.
    Still the same problem…

    wpsolr
    Keymaster
    # 1 year, 5 months ago

    Could you copy here a link to your PDF? I’d like to try index it.

    AlaplayaW
    Participant
    # 1 year, 5 months ago

    The link is on an amazon bucket s3. For exemple with a 110MB document.
    It is the same document that I try to import. The import in WP is ok but not indexed.
    (removed)

    • This reply was modified 1 year, 5 months ago by wpsolr.
    wpsolr
    Keymaster
    # 1 year, 5 months ago

    Thanks, I got the file.

    wpsolr
    Keymaster
    # 1 year, 5 months ago

    I could import and index your PDF.
    It seems like your PHP max memory settings are not used for any reason.

    AlaplayaW
    Participant
    # 1 year, 5 months ago

    ok I don’t understand why, I hope it will be ok in prod …

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.