"Generate a permalink for this facet" resulting in a 404 page

  • programmer
    Participant
    # 9 months, 2 weeks ago

    Hello,

    I am trying to setup facets to use permalinks rather than query strings. For example, I have setup /search/category1 or /search/category2 to filter results. However, the links result in a 404 page. The main slug is set to /search. I feel like I must be missing some setting, but I can not find any documentation in it. Any ideas?

    wpsolr
    Keymaster
    # 9 months, 1 week ago

    Thanks for the feedback.

    I confirm that the /search permalink is not recognised yet.

    It will be fixed in the next release, which should occur this week or next week at least.

    wpsolr
    Keymaster
    # 9 months, 1 week ago

    Sorry, I misunderstood your question.

    Is it about the Yoast SEO extension and its search permalink ?

    programmer
    Participant
    # 9 months, 1 week ago

    Thanks for the quick reply. Hopefully, the below image helps illustrate what I’m trying to do. Basically, I have disabled AJAX filters and I’m trying to get the URLs to reflect the selected filters. For example /category/example or /category/test as opposed to /search?category=example. But when I enable this the pages display a 404 error.

    https://www.dropbox.com/s/f13mokg5kc05tvj/wpsolr.png?dl=0

    wpsolr
    Keymaster
    # 9 months, 1 week ago

    It seems you use our Yoast SEO extension extension.

    If so, search permalinks are generated automatically, based on your configuration.

    See tutorial:

    Video – WPSOLR PRO + Yoast SEO + TwentySixteen + SolrCloud

    programmer
    Participant
    # 9 months, 1 week ago

    That did the trick. I knew I was missing some simple setting. Thank you!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.