facets not updated after updating a WooCommerce product attribute label

  • rvs
    Participant
    # 2 years, 1 month ago

    Hi

    I have edited a woocommerce attribute value.

    I purged al cache, cleared transients, cleared term counting

    On the front-end it still shows up in the WPSOLR facets.
    I added as test a woocommerce filter, there is my edit visible?

    1. is there a cache on the WPSOLR facets?
    2. do i need a manual reindex (don’t hope so) ?
    3. is it indexing still busy in the background?

    wpsolr
    Keymaster
    # 2 years, 1 month ago

    Yes, you will need to reindex all products if you change taxonomies content, like product attributes.

    Indexing is quite intensive on WP side, as it requires lots of data queries. You can use our Cron extension to index by batch at your most convenient hour.

    rvs
    Participant
    # 2 years, 1 month ago

    Is there a manual, when i click the blue question mark icon from the extension admin page. I get redirected to multiple search results. Do i need to get the information from all those forum posts?

    Sorry but its not clear to me.

    rvs
    Participant
    # 2 years, 1 month ago

    I managed it, but could be easier 😉

    rvs
    Participant
    # 2 years, 1 month ago

    Hi i enabled the cron option.
    Cron did run last night, but there are still products that need to be indexed?

    Cronlog (x is blackedout)

    May 27 01:00:01 185405 CRON[19548]: (XXXXXXX) CMD (curl -X GET -H “Content-type: application/json” -H “Accept: application/json” -u wpsolr-cron:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX “https://xxx.xxxxxxxxx.xx/wpsolr-api/json/cron/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX”)

    rvs
    Participant
    # 2 years, 1 month ago
    wpsolr
    Keymaster
    # 2 years, 1 month ago

    You can check the logs in your WPSolr cron settings screen. You will get statistics or errors.

    rvs
    Participant
    # 2 years, 1 month ago

    It says No log available ?

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.