Facets are not visible on product attribute archive pages

  • finalwebsites
    Participant
    # 2 months ago

    Hi,
    I get the facets on the shop pages and product categories, but not on archives for product attributes. Is there a specific reason or a workaround to enable them here as well?
    Regards
    Olaf

    wpsolr
    Keymaster
    # 2 months ago

    I was not aware of product attribute archives. How do you show them?

    finalwebsites
    Participant
    # 2 months ago

    Hi,

    For set the option “Activate archives” for each attribute you create.
    This way you get archives like these: https://hafabramuziekshop.nl/uitgever/acanthus-music/

    wpsolr
    Keymaster
    # 2 months ago

    Thanks.

    Product attributes being custom categories in recent WooCommerce, their archives are powered by WPSOLR as other categories. I just tested on a local environment, with a colour attribute.

    Just be sure that:
    – Option “search categories” is selected in the WooCommerce extension
    – The attribute is selected in products taxonomies(screen 2.2), and indexed.

     

     

    finalwebsites
    Participant
    # 2 months ago

    Hi,

    I double checked both settings and the facets are visible on this product category:
    https://hafabramuziekshop.nl/categorie/harmonie/
    and also in the search result page:
    https://hafabramuziekshop.nl/?s=mozart&post_type=product

    The problem exists only on the attribute archive pages (which is an old feature from ver. 2.xx)

    wpsolr
    Keymaster
    # 2 months ago

    which is an old feature from ver. 2.xx

    What do you mean?

    wpsolr
    Keymaster
    # 2 months ago

    You need to update to WPSOLR 21 6:
    * New! (WooCommerce add-on) Replace search for all custom product taxonomies

    finalwebsites
    Participant
    # 2 months ago

    Hi,

    thanks for the fast update 🙂

    The product attributes archive is not a new feature, it exists since WooCommerce version 2.x or before

    finalwebsites
    Participant
    # 2 months ago

    with the new version it’s working, thanks

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.