Error while configuring settings

Tagged:
  • priyanka_kethireddy
    Participant
    4 months, 4 weeks ago #30263

    Hello Team,
    While we are configuring solr in one of our sites we are getting below error

    {“error”:{“root_cause”:[{“type”:”illegal_argument_exception”,”reason”:”Text fields are not optimised for operations that require per-document field data like aggregations and sorting, so these operations are disabled by default. Please use a keyword field instead. Alternatively, set fielddata=true on [type] in order to load field data by uninverting the inverted index. Note that this can use significant memory.”}],”type”:”search_phase_execution_exception”,”reason”:”all shards failed”,”phase”:”query”,”grouped”:true,”failed_shards”:[{“shard”:0,”index”:”sitename_live”,”node”:””,”reason”:{“type”:”illegal_argument_exception”,”reason”:”Text fields are not optimised for operations that require per-document field data like aggregations and sorting, so these operations are disabled by default. Please use a keyword field instead. Alternatively, set fielddata=true on [type] in order to load field data by uninverting the inverted index. Note that this can use significant memory.”}}],”caused_by”:{“type”:”illegal_argument_exception”,”reason”:”Text fields are not optimised for operations that require per-document field data like aggregations and sorting, so these operations are disabled by default. Please use a keyword field instead. Alternatively, set fielddata=true on [type] in order to load field data by uninverting the inverted index. Note that this can use significant memory.”,”caused_by”:{“type”:”illegal_argument_exception”,”reason”:”Text fields are not optimised for operations that require per-document field data like aggregations and sorting, so these operations are disabled by default. Please use a keyword field instead. Alternatively, set fielddata=true on [type] in order to load field data by uninverting the inverted index. Note that this can use significant memory.”}}},”status”:400}

    wpsolr
    Keymaster
    4 months, 4 weeks ago #30264

    It could means that you are using a field as filter on screen 2.4, which has also been configured on screen 2.2 with type “Text, if too long for other text types (cannot be used as facet)”

    priyanka_kethireddy
    Participant
    4 months, 4 weeks ago #30266

    It was little bit confusing, because we are using same settings for all sites, those are working fine, only in one site we are getting this error.

    priyanka_kethireddy
    Participant
    4 months, 4 weeks ago #30287

    Issue got fixed, Thanks

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.