Error When Attempting To Index

  • snfpaper
    Participant
    # 1 month ago

    Recently, we attempted to index media on our website (www.snfpaper.org), but received the following error and no media would be indexed. We aren’t sure what this error means.

    An error occured:
    Solr HTTP error: OK (400) { “responseHeader”:{ “status”:400, “QTime”:5}, “error”:{ “metadata”:[ “error-class”,”org.apache.solr.common.SolrException”, “root-error-class”,”java.lang.NumberFormatException”], “msg”:”ERROR: [doc=297] Error adding field ‘displaymodified_dt_i’=’1528495586000’ msg=For input string: \”1528495586000\””, “code”:400}}

    Please advise. Thank you.

    wpsolr
    Keymaster
    # 2 weeks, 6 days ago
    snfpaper
    Participant
    # 2 weeks, 6 days ago

    Thank you for the response. Do we have to delete the first index before creating the new one? We attempted to create a new index, with a different name from the first. After filling out the initial information, we were prompted to download a .zip file, which we did, and unzipped it in the designated folder. We clicked the “Check index status” button afterward, but we received an http error. Then we tried https instead, and received a cURL error. And upon switching back to http, we received a message telling us that “this index name already exists”.

    And above that, in orange, it says, “Connect to your index (Loading the index…)”

    Please advise. Thanks!

    wpsolr
    Keymaster
    # 2 weeks, 6 days ago

    Do not delete the first index until the new index is created and indexed with all your documents. Then select the new index on screen 2.1, and delete the first index if all is fine.

    Please check the Solr index creation documentation https://www.wpsolr.com/guide/configuration-step-by-step-schematic/configure-your-indexes/connect-to-an-apache-solr-index/

    The first video should show you all the steps.

    snfpaper
    Participant
    # 2 weeks, 6 days ago

    That worked – thank you so much for your assistance! The new index is working now without any errors.

    How do we delete the first index? We watched the video and followed the steps, but our old index is still sitting in there beside the new one.

    wpsolr
    Keymaster
    # 2 weeks, 6 days ago

    To delete the index, in WPSOLR navigate to the index settings, and click “Delete this configuration” with the “delete the index” checkbox selected.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.