Error saving existing index configuration

  • pseudo visitor
    Participant
    # 1 year ago

    It is no longer possible to save the configuration: after clicking the button, colour changes for a short time to green and then it changes back to red.

    wpsolr
    Keymaster
    # 1 year ago

    Are you mentioning the index screen ?

    What is the error message ?

    Anything in your debug.log ?

    pseudo visitor
    Participant
    # 1 year ago

    Meantime I deleted the existing index.

    By trying create a new index, I received an error message:

    We could not join your Solr server. Your Solr path could be malformed, or your Solr server down (Solr code 400) 
    {"responseHeader":{"status":400,"QTime":2},"error":{"metadata":["error-class","org.apache.solr.common.SolrException","root-error-class","org.apache.solr.core.SolrResourceNotFoundException"],"msg":"Error CREATEing SolrCore 'my_index': Unable to create core [my_index] Caused by: Can't find resource 'solrconfig.xml' in classpath or '/usr/home/site/solr/server/solr/configsets/my_index'","code":400}}
    wpsolr
    Keymaster
    # 1 year ago

    You must install the configuration files for your index. Commands are listed with the index settings.

    Video – Create an Apache Solr index semi-automatically

    pseudo visitor
    Participant
    # 1 year ago

    I did so. But there are no search results available, and the web page shows: “The search index is missing. Configure one in the Solr indexes, and select it in the default search Solr index list.”

    wpsolr
    Keymaster
    # 1 year ago

    You need to create a new index (change the path: /solr/another-name-here), to see the commands to execute on your Solr server.

    Your current index is misconfigured somehow.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.