Error on page with “solr_search_shortcode” shortcode

Tagged:
  • danmaby
    Participant
    2 weeks, 6 days ago #31496

    Hi, I’m trialling the plugin and have an issue with the “solr_search_shortcode" shortcode. When placed on a page, it returns a JSON error and makes the page inaccessible via the admin. When accessing a page in the wp-admin with the shortcode included, a blank page is returned with the message: “The search index is missing. Configure one in the Solr indexes, and select it in the default search Solr index list”. However, the index is configured and functioning on the front end? The site is running the latest versions of the plugin and WordPress. The server is running PHP7.4.

    wpsolr
    Keymaster
    2 weeks, 6 days ago #31499

    Did you select your index as the search index on screen 2.1 ?

    Warning: the shortcode is deprecated.

    danmaby
    Participant
    2 weeks, 6 days ago #31500

    Thanks for the quick response; much appreciated.

    Are you referring to the Search with this search engine index option? If so, then yes. This is selected with the index.

    How do I display the search on a specific page if the shortcode is deprecated?

    wpsolr
    Keymaster
    2 weeks, 6 days ago #31501

    How do I display the search on a specific page if the shortcode is deprecated?

    WPSOLR is replacing archive queries, and let your theme work as usual with the post loop to display results.
    The shortcode is necessary on cross-domain search, when the current theme’s post loop cannot get details of external post ids

    This is selected with the index.

    Is the selected search template, on same 2.1 page, the “deprecated” shortcode?

    danmaby
    Participant
    2 weeks, 6 days ago #31503

    Now I know the shortcode is deprecated, it makes more sense. Thanks for your help.

    On a side note – in the forum here, the Google Captcha iFrame has a height set to 394px; which I need to disable each time to access the Add Reply button.

    .entry-content embed, 
    .entry-content iframe, 
    .entry-content object, 
    .entry-content video. {
        margin-bottom: 25px;
        width: 100%;
        height: 394px;
    }
    wpsolr
    Keymaster
    2 weeks, 6 days ago #31506

    Thanks for the tip ! (fixed)

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.