Test index: Can’t get plugin to send data

  • makeworthy
    Participant
    # 2 weeks, 5 days ago

    Hi, I’m testing the plugin to see if it is a good solution for a client. I’m using the free 2-hour “Test index from Elastic Cloud.” When I get to “Step 3: Send your data” I get an error every single time I click the “Index selected post types in index ‘Test index from Elastic Cloud'” button, no matter what posts, pages, etc. that I ask it to index. When I have the debugging checkbox checked, the error is:

    An error or timeout occured.
    Error code: parsererror
    Error message: SyntaxError: Unexpected token P in JSON at position 0

    When I don’t have the debugging checkbox checked, the error message is:

    An error occured:
    mapper [id] cannot be changed from type [keyword] to [long]

    I tried blocking the ID of the first post listed in the error output text, but that didn’t fix anything because the next post ID also generated the error. I also tried reducing the number of posts being index in a batch to 25 and that didn’t fix it either. As a test, I created just 1 post and tried to index just that, and still got the error.

    Do you have any insight into what might be happening here? Is there a known conflict with another plugin or theme? Thanks!

    makeworthy
    Participant
    # 2 weeks, 5 days ago

    It looks like it was something theme related. I tried activating the Twenty Twenty theme and was able to index after that. Still not sure what is happening in the theme to cause this, so if you have any ideas, let me know. Otherwise you can close this thread.

    wpsolr
    Keymaster
    # 2 weeks, 5 days ago

    The test index is deprecated and will be removed in next release. The test Elasticsearch mapping is not compatible anymore with WPSOLR’s, hence the mapping error.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.