Can't Connect to SearchStax

  • jay
    Participant
    # 1 year, 9 months ago

    I’m trying to connect to SearchStax and I keep getting “We could not join your Solr server. Your Solr path could be malformed, or your Solr server down (Solr code 404)”.

    WPSOLR index name: Test
    Server Protocol: https
    Server Host: xxxxxxxxx-xxxxxxxx-us-east-2-aws.searchstax.com/solr/
    Server Port: 8983
    Solr index path: /Test or /solr/Test

    Testing with WPSolr 20.1

    wpsolr
    Keymaster
    # 1 year, 9 months ago

    You can try:

    Serach engine: SolrCloud
    WPSOLR index name: Test
    Server Protocol: https
    Server Host: xxxxxxxxx-xxxxxxxx-us-east-2-aws.searchstax.com
    Server Port: 443
    Solr index path: /solr/test

    jay
    Participant
    # 1 year, 9 months ago

    That produces:
    We could not join your Solr server. Your Solr path could be malformed, or your Solr server down (Solr code 400)

    { “responseHeader”:{ “status”:400, “QTime”:7}, “error”:{ “metadata”:[ “error-class”,”org.apache.solr.common.SolrException”, “root-error-class”,”org.apache.solr.common.SolrException”], “msg”:”Error CREATEing SolrCore ‘Test’: non legacy mode coreNodeName missing {configSet=Test}”, “code”:400}}

    wpsolr
    Keymaster
    # 1 year, 9 months ago

    With engine “SolrCloud” or “Solr”?

    jay
    Participant
    # 1 year, 9 months ago

    I forgot to change it to SolrCloud, I’ll try again.

    jay
    Participant
    # 1 year, 9 months ago

    For a Test collection:
    { “responseHeader”:{ “status”:400, “QTime”:9}, “Operation create caused exception:”:”org.apache.solr.common.SolrException:org.apache.solr.common.SolrException: collection already exists: Test”, “exception”:{ “msg”:”collection already exists: Test”, “rspCode”:400}, “error”:{ “metadata”:[ “error-class”,”org.apache.solr.common.SolrException”, “root-error-class”,”org.apache.solr.common.SolrException”], “msg”:”collection already exists: Test”, “code”:400}}

    wpsolr
    Keymaster
    # 1 year, 9 months ago

    Collection /solr/test exists. use another collection name /solr/test1

    jay
    Participant
    # 1 year, 9 months ago

    I see Test1 was created in the cloud tree.
    { “responseHeader”:{ “status”:400, “QTime”:1459}, “failure”:{ “10.0XX.XXX.XXX:8983_solr”:”org.apache.solr.client.solrj.impl.HttpSolrClient$RemoteSolrException:Error from server at https://10.0XX.XXX.XXX:8983/solr: Error CREATEing SolrCore ‘Test1_shard1_replica_n1’: Unable to create core [Test1_shard1_replica_n1] Caused by: The configset for this collection was uploaded without any authentication in place, and use of is not available for collections with untrusted configsets. To use this component, re-upload the configset after enabling authentication and authorization.”}, “Operation create caused exception:”:”org.apache.solr.common.SolrException:org.apache.solr.common.SolrException: Underlying core creation failed while creating collection: Test1″, “exception”:{ “msg”:”Underlying core creation failed while creating collection: Test1″, “rspCode”:400}, “error”:{ “metadata”:[ “error-class”,”org.apache.solr.common.SolrException”, “root-error-class”,”org.apache.solr.common.SolrException”], “msg”:”Underlying core creation failed while creating collection: Test1″, “code”:400}}

    wpsolr
    Keymaster
    # 1 year, 9 months ago

    Recent versions of SolrCloud require that the user you use to create the index has also the rights to upload the configuration files.

    Source: https://lucene.apache.org/solr/guide/8_4/configsets-api.html#configsets-upload

    A configset is uploaded in a “trusted” mode if authentication is enabled and the upload operation is performed as an authenticated request

    This can be done only in SearchStax.

    jay
    Participant
    # 1 year, 9 months ago

    I’ll see what I can do.
    Thank you

    jay
    Participant
    # 1 year, 9 months ago

    I’m getting close, I got authentication failed.

    jay
    Participant
    # 1 year, 9 months ago

    Hi,
    I’m out of options, even with the help from you and from SearchStax, I can’t connect to them.
    I’m just going to have to host Solr myself for production.

    wpsolr
    Keymaster
    # 1 year, 9 months ago

    I contacted SearchStax support, to get my SearchStax deployment updated to SolrCloud 8.4
    With my current 7.5 deployment, WPSOLR can create the index.

    jay
    Participant
    # 1 year, 9 months ago

    Does my version of WPSOLR matter? I’m connecting using my local home environment if that matters using WAMP.

    wpsolr
    Keymaster
    # 1 year, 9 months ago

    SearchStax support kindly installed me a deployment with Solr 8.4.0, and I could create an index from WPSOLR.

    2 conditions appear to be necessary:
    – Create a user/pwd and use it during index creation with WPSOLR. The user will automatically be added to security.json as an authenticated user with permissions to upload the config files.
    – Add an IP filter in your deployment security menu:
    > “IP/Range in CIDR format”: 0.0.0.0/0
    > “Service”: Solr

Viewing 15 posts - 1 through 15 (of 23 total)

You must be logged in to reply to this topic.