Bug: Clicking back from filters

  • mcl7
    Participant
    # 11 months ago

    Using Algolia. On a search page:

    If you do a search for something then select one of the filters, then click back – the URL does change back to the previous URL you were on – but the results remain the same (still filtered).

    If I select the first filter (filter1), then select a second filter(filter2), then click back it successfully goes back to just showing filter1. However, if I click back again it fails to go back to the original query page.

    • This topic was modified 11 months ago by wpsolr.
    • This topic was modified 11 months ago by wpsolr.
    wpsolr
    Keymaster
    wpsolr
    Keymaster
    # 10 months, 1 week ago

    I can reproduce your issue when search results are not configured to be refreshed with Ajax (thanks to the “Theme” add-on).
    Can you confirm?

    wpsolr
    Keymaster
    # 10 months, 1 week ago

    You can find a fix on https://trello.com/c/CpT1BoHo/114-bug-clicking-back-from-filters-with-ajax

    • This reply was modified 10 months, 1 week ago by wpsolr.
    • This reply was modified 10 months ago by wpsolr.
    mcl7
    Participant
    # 10 months ago

    Thank you! How should I go about updating? Will I need to reinstall or can I copy over the existing folder and keep all my settings?

    wpsolr
    Keymaster
    # 10 months ago

    Just replace your WPSOLR version. Settings will be kept.

    Be sure to clear your caches, as a js file was updated.

    mcl7
    Participant
    # 10 months ago

    This issue is resolved. I found a more minor issue though but will post in a separate ticket.

    wpsolr
    Keymaster
    # 2 months, 1 week ago
Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.