Simple Elastic cloud setup

  • support
    Participant
    2 years, 4 months ago #21373

    Dear WPSolr team,

    I’ve bought your plugin and during the initial install phase I can’t get further than the “Connect to your index (Loading the index …)” phase.

    By following the tutorial on https://www.wpsolr.com/guide/configuration-step-by-step-schematic/configure-your-indexes/create-an-elastic-elasticsearch-index/ I get every time the same error “No alive nodes found in your cluster”, but I just created it and my node is up and running.
    This doesn’t change even if I try Elasticsearch version 7.8.1, 7.8.0 or 6.8.11

    Here is a screenshot of my setup: https://pasteboard.co/JjNcPLg.png

    So, I don’t really understand what’s going wrong.

    Is there any way to debug at this phase?
    I didn’t find any WPSolr related log in the php_error.log

    Are there any requirements in order to use the plugin?

    Thank you.

    Best regards,

    Hendrik

    wpsolr
    Keymaster
    2 years, 4 months ago #21374

    Can you cURL your endpoint from your WP server (ssh)?

    You can also try without the port number (:9243). Some WP hostings block all ports but 443.

    support
    Participant
    2 years, 4 months ago #21375

    I’m talking to the support team and yes, the hosting provider might be causing the issue by blocking the call on this port.

    Thank you.

    wpsolr
    Keymaster
    2 years, 4 months ago #21377

    Which WordPress hosting provider is it?

    Splitreq
    Participant
    2 years, 3 months ago #21495

    I had the same problem. Port 9200 was blocked on my VPS. Also remember to enable basic authentication in elasticsearch. After I did that it connected fine.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.