Field Configuration will not save

  • insideout
    Participant
    # 6 months, 1 week ago

    We have a fairly large site with ~1000 ACF fields and multiple different post types. Site is completely custom.

    Installed the latest version of the Pro plugin (All plugins available, only Cron, ACF, and Premium enabled), and the latest version of Apache Solr ( 8.0.0 ), but every time I try to select multiple ACF fields for a specific post type, the entire configuration is reset and none of the changes are ever saved. I can save one (1) post type at a time, but once the configuration gets above 6 – 7 ACF fields per type, or when there are more than 100 ACF fields on a specific post type (even if they are not selected for the configuration), the entire configuration is wiped out and I have to re-do the configuration.

    I have tried with the 2019 theme as well as disabling all of other plugins.

    There are no errors in the error logs, console logs, or in the SOLR logs (as I have not even been able to get to the point of indexing the data yet).

    Is there anywhere I can debug what is happening when saving the configuration to the database?

    wpsolr
    Keymaster
    # 6 months, 1 week ago

    All 2.2 settings are saved in a single WP option. Perhaps there is a size on saving a single option?

    insideout
    Participant
    # 6 months, 1 week ago

    The current field size is a MySQL / MariaDB longtext, which can handle 4GB of data ( 4,294,967,295 or 4GB (232 − 1), see https://dev.mysql.com/doc/refman/8.0/en/string-type-overview.html ), but the field length is around 77K characters.

    I checked that one, too.

    mysql> SELECT option_name, LENGTH(option_value) FROM ******** WHERE option_name LIKE '%solr%';
    +-------------------------------------------+----------------------+
    | option_name                               | LENGTH(option_value) |
    +-------------------------------------------+----------------------+
    | widget_wpsolr_widget_facets               |                   30 |
    | widget_wpsolr_widget_sort                 |                   30 |
    | wpsolr_solr_indexes                       |                  855 |
    | wdm_solr_extension_acf_data               |                   93 |
    | wdm_solr_cron                             |                  681 |
    | wdm_solr_premium                          |                   60 |
    | wdm_solr_res_data                         |                  445 |
    | wdm_solr_form_data                        |                77442 |
    | solr_docs                                 |                   53 |
    | solr_last_post_date_indexed               |                  517 |
    | wdm_solr_operations_data                  |                  339 |
    | solr_docs_added_or_updated_last_operation |                  158 |
    +-------------------------------------------+----------------------+
    12 rows in set (0.00 sec)
    

    It looks like you are using a serialized array to store the data. I will see if I can unserialize it and get the data back out to see if that’s the issue.

    insideout
    Participant
    # 6 months ago

    This is solved. It took manually removing the “custom_field_properties” caching item from the serialized array, as well as manually defining, building, and serializing the arrays that built the options out rather than using the GUI.

    wpsolr
    Keymaster
    # 6 months ago

    Is there something that could be integrated in the plugin?

    insideout
    Participant
    # 5 months, 4 weeks ago

    The only suggestion I would have is to split the caching configuration “custom_field_properties” into a separate option_value rather than trying to combine it with the “cust_fields” configuration.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.