Forum Replies Created
-
matteo.cattelanParticipant2 years, 11 months ago in reply to: WPSOLR_Query did you mean and filter by date #36974
I’m only interested in the name of the parameters to pass to the wpsolr query
matteo.cattelanParticipant2 years, 11 months ago in reply to: Remove 10000 limit when using elasticsearch #36964I have Open Search for engine, but is the fork to Elastic and i aspect have the same options.
matteo.cattelanParticipant2 years, 11 months ago in reply to: Remove 10000 limit when using elasticsearch #36963I’m haven’t this options.
matteo.cattelanParticipant2 years, 11 months ago in reply to: Remove 10000 limit when using elasticsearch #36961I have WPSOLR PRO 23.4, where can i found the screen?
matteo.cattelanParticipant2 years, 11 months ago in reply to: Remove 10000 limit when using elasticsearch #36959Any news for this issue?
matteo.cattelanParticipant2 years, 11 months ago in reply to: WPSOLR_Query did you mean and filter by date #36955But in wpsolr_query i have a “q” parameter, i thought that was the parameter to use.
Change the question. How pass to wpsolr_query a facet of date filter? In other words:
Is it possible to create a personal filter that has a date?Many thanks
matteo.cattelanParticipant2 years, 11 months ago in reply to: WPSOLR_Query did you mean and filter by date #36953For suggestions i solved.
For the date filter however I cannot use the normal WordPress query_date functions. Is there a way to pass a query to Open search?Thanks again…
Byematteo.cattelanParticipant3 years ago in reply to: Excerpt of results not show #35650thank you very much for the clarification, too kind but I have already solved it with the hook solution.
Thanks
matteo.cattelanParticipant3 years ago in reply to: “Did you mean” error #35639Ok i understand, last question:
Can I change the parameter to all indexes without losing the index of the articles?Thanks a lot for all, now the situation is more clear.
matteo.cattelanParticipant3 years ago in reply to: “Did you mean” error #35637All index is created with WPSOLR
matteo.cattelanParticipant3 years ago in reply to: “Did you mean” error #35635Yes for English “did you mean” work but i have 5 languages.
matteo.cattelanParticipant3 years ago in reply to: “Did you mean” error #35632it exists but only in the English index… in other languages it is not present, but the plugin does this when it creates the index…
My OpenSearch version is: OpenSearch_1_2_R20221114-P3 (latest)matteo.cattelanParticipant3 years ago in reply to: Excerpt of results not show #35628ok, this issue is closed for me, thanks a lot for all.
matteo.cattelanParticipant3 years ago in reply to: “Did you mean” error #35627Yes the index is created by WPSOLR, please, give me an example of definition for field spell.
Thanks a lot for all.
matteo.cattelanParticipant3 years ago in reply to: Excerpt of results not show #35624If i active the option in Wpsolr backend in wordpress i have this error:
{“error”:{“root_cause”:[{“type”:”illegal_argument_exception”,”reason”:”no mapping found for field [spell]”}],”type”:”search_phase_execution_exception”,”reason”:”all shards failed”,”phase”:”query”,”grouped”:true,”failed_shards”:[{“shard”:0,”index”:”wp_it”,”node”:”GbLND5ZMSrqT3nD1giH9Ew”,”reason”:{“type”:”illegal_argument_exception”,”reason”:”no mapping found for field [spell]”}}],”caused_by”:{“type”:”illegal_argument_exception”,”reason”:”no mapping found for field [spell]”,”caused_by”:{“type”:”illegal_argument_exception”,”reason”:”no mapping found for field [spell]”}}},”status”:400}Do I need to configure something?
Thanks a lot- This reply was modified 3 years ago by matteo.cattelan.