Filters are gone and the archive page has huge whitespace on top

  • finalwebsites
    Participant
    # 1 month ago

    According the logs there is something with my series attribute. So I checked the number from that attribute and noticed that there is no product for this attribute. While removing all empty attribute records I get this error:

    (WPSOLR) Error while indexing this post type:

    {“error”:{“root_cause”:[{“type”:”query_shard_exception”,”reason”:”failed to create query: {\n \”bool\” : {\n \”must\” : [\n {\n \”term\” : {\n \”id\” : {\n \”value\” : \”pa_series_32766\”,\n \”boost\” : 1.0\n }\n }\n }\n ],\n \”adjust_pure_negative\” : true,\n \”boost\” : 1.0\n }\n}”,”index_uuid”:”q0gVWxc6Tb-bcDdG1qlITQ”,”index”:”hafabra_index_new”}],”type”:”search_phase_execution_exception”,”reason”:”all shards failed”,”phase”:”query”,”grouped”:true,”failed_shards”:[{“shard”:0,”index”:”hafabra_index_new”,”node”:”64_mCJnUSO-tD72bkdrQlg”,”reason”:{“type”:”query_shard_exception”,”reason”:”failed to create query: {\n \”bool\” : {\n \”must\” : [\n {\n \”term\” : {\n \”id\” : {\n \”value\” : \”pa_series_32766\”,\n \”boost\” : 1.0\n }\n }\n }\n ],\n \”adjust_pure_negative\” : true,\n \”boost\” : 1.0\n }\n}”,”index_uuid”:”q0gVWxc6Tb-bcDdG1qlITQ”,”index”:”hafabra_index_new”,”caused_by”:{“type”:”number_format_exception”,”reason”:”For input string: \”pa_series_32766\””}}}]},”status”:400}

    How to solve this?

    wpsolr
    Keymaster
    # 1 month ago

    It seems to be a format issue with field “pa_series_32766”. Go to screen 2.2, and check that type “String” is selected for this field. Then reindex all.

    • This reply was modified 1 month ago by  wpsolr.
    finalwebsites
    Participant
    # 1 month ago

    Hi,
    This is not a field, pa_series is a product attribute (woocommerce taxonomy)
    And for the taxonomies is not such a string type

    wpsolr
    Keymaster
    # 1 month ago

    Can you remove it from the boosts in screen 2.3, and see what happens?

    finalwebsites
    Participant
    # 1 month ago

    I don’t use boosts, the check box is not activated

    finalwebsites
    Participant
    # 1 month ago

    it’s working now, maybe I need to save some option after I did the settings import from the other website.
    Thanks

    finalwebsites
    Participant
    # 1 month ago

    Sorry I was in the wrong site, same settings but the problem still exists
    (boosts are disabled)

    wpsolr
    Keymaster
    # 1 month ago

    Can you also remove all fields in screen 2.3 and save?

    finalwebsites
    Participant
    # 1 month ago

    saving doesn’t work, it says “saving” for several minutes now.

    wpsolr
    Keymaster
    # 1 month ago

    Try to check your debug.log errors.

    finalwebsites
    Participant
    # 1 month ago

    Saving works after I entered some values to the required fields.
    Now all boost fields are disabled, the activate boots is unchecked.
    The problem still exists.

    wpsolr
    Keymaster
    # 1 month ago

    Can I see the new error message?

    finalwebsites
    Participant
    # 1 month ago

    The error in the cron log is gone, but now I see this error if I click index button:

    failed to parse field [id] of type [long] in document with id ‘pa_instrument_31988’

    finalwebsites
    Participant
    # 1 month ago

    Just check the database and term record with id 31988 looks fine.
    What I see is that there are multiple terms having the same slug (this is some mess from the site owner)

    finalwebsites
    Participant
    # 1 month ago

    Hi,

    is there something else I can try?

Viewing 15 posts - 1 through 15 (of 38 total)

You must be logged in to reply to this topic.